Cannot connect FrSky R-XSR to Mamba F405 MK4

Hi, this is my first time writing here!

I’m trying to use ardupilot on my fpv drone. I have inside a mamba F405 MK4 with a FrSky R-XSR as a receiver for my radio.
I soldered the SBUS out of the receiver on the RX1 of the FC. No S.Port.
On the Radio calibration page I don’t see any input.
I’ve tried SERIAL1_PROTOCOL = 23 and 3. SERIAL1_OPTION = 0, 1, 2, 3, 132.

Nothing works.
Can somebody help?

Post a link to the exact flight controller you have and your parameters. I did all the Mamba ports and the naming is a little tricky to navigate.

This is the FC: the image corresponds with mine Mamba MK4 F405Mini — Copter documentation

I think mine is version B, i’m not sure but the imu is working so I don’t think that is the problem.

At this link you can find my param list. I flashed this firmware now just to test the controller so everything exept SERIAL1 should be defaulted.


So did you load the firmware MambaF405-2022?

Also you must just set one serial protocol to 23 - if you set multiple only one will be used and probably not the one you want

Yes I installed the F405-2022, but i tried the other ones for mamba F405 and nothing works.

I just tried to put serial1 to 23 and all the other ones to -1, no changes. Still cannot see any input.


SBUS requires hardware inversion which will only work on SERIAL1. So you must use SERIAL1, but it seems its not working - my guess is that the hardware inversion is the issue.

I also tried using the uninverted pin that I soldered to from the receiver to RX1 of the FC. Still doesn’t work.

@Stefano_Giulianelli did you resolve this? If so can you please inform me how you resolved it? I recently tried the same i am facing a similar issue but with a different Sbus receiver. I connected the Sbus port of receiver to RX1 pin of FC.