Cannot Connect APM 2.6 to Computer?

Hi I’m fairy new to apm, but I cannot get my windows 10 pc to recognize the apm. It’s not listed in the device manager so my computer for sure cannot see it. Are there drivers for me to download? Ive tried different usb ports and cables, different computers running win 10 but the apm doesn’t show up in any type of software. It lights up flashing red and blue with a steady green if that helps at all.

Have you installed ground control station yet? If not grab Mission Planner from When you install it from the .msi file it will install the drivers you need.


Hello. I had the same problem, and after installing tons of drivers, I realize the problem was de cable. Please be sure that is a data USB-microUSB cable, and not only a charging cable. Those have only connected pins 1 and 4.

I may try reinstalling mission planner if for some reason the drivers never installed, but yes I am using a data microusb cable.

EDIT: reinstalled mission planner, everything works now thanks.

Hello i am having the same problem and have tried everything. i have used Windows,Mac and Linux but it never shows up. i will try reinstalling apm planner as it is called that now tonight.

also I have same problem,. at windows 10 lenovo laptop, I couldn’t connect the ardupilot. At device manager com port is not recognized. blue led is always lighting, red led is blinking. I need your help.

I tried lots of drivers, ardunio IDE and mission planner instalations. But they are worthless.