Can you overrride the absurd 8000cm RTL_ALT limit somehow?

Ideally I am hoping there is a setting like return home 200ft above current height instead of the regular “crash airplane” setting that it defaults to.

APM only lets you set a maximum of 8000cm above launch for RTL but this is problematic in two ways:

  1. Sometimes RTL engages because the dummy flying the plane flies behind a hill and it would be better if the plane to flew back up and over the hill instead of straight into the side of it.
  2. If I fly uphill more than 400ft and RTL engages APM just plants the airplane into the ground instead of flying above the ground.

I am still waiting for the technology to come out will allow me to attach a drill to my plane and fly seamlessly through the ground like they do in the cartoons but until then I’m stuck having to fly over the ground

Are you saying that’s a new restriction in 3.3.0? (I’m still using 3.2.3).
What is your ALT_HOLD_RTL set to?
Do you have terrain following enabled?

In 3.2.3 I’m able to use 20000 for ALT_HOLD_RTL just fine and since I fly in a mountainous area thousands of feet above my launch point, I know for sure that the terrain following works well to stay above the hills as needed. I’ve tested it many times.


the limit is over 21km, as it is a signed 32 bit number.
Why do you think it is 80m?

btw, I assume you have seen this: … following/
terrain following for RTL is rather useful

because that is the max limit allowed on APM … 52100a.jpg

I haven’t tried terrain following yet. Does it work if you travel all over the place or can you only download one area’s terrain map?

those are parameters for copter, not plane
do you have plane firmware loaded? If you do, then it may be a MissionPlanner error

The terrain data is relatively small even at 30m sampling, so you can store a vast area on the microSD card in the pixhawk. You need to define a mission which enters a grid square for that one to be downloaded. Each square is several KM on a side and many will fit in the uSD.

Maybe that’s the problem.
I installed an APM into a copter back in January and now I am attempting to configure a plane. I downloaded Arduplane but maybe it didn’t override Arducopter like I thought it did. I will do a complete uninstall/reinstall and see if that fixes things.