Can´t connect to MavLink

I received my new Ardupilot 2.5 and after install the Arducopter firmware I can´t connect to MavLink. I´ve tryed several firmares and only one time I´ve connect with Arduplane firmware. I don´t know what to do more. Can anyone help.

[color=#004000]Please provide complete information![/color]
What firmware version are you using?
How do you try to connect (USB/3DR radio/Xbee/…)?
What exactly happens? What is the error message! If possible, provide a screenshot!

I use APM 2.5.2. I install firmware Arducipter V3.0.1 Quad. I use Mission planner 1.2.85. When I try to connect, jn my case Com5, 115200 kbs, it neves connects, it gives the error " No heatbeat packets received". The only time that I’ve connect was with Arduplane V2.75 firmware. I’m connecting with USB cable.

Is your APM2.5 a 3DR APM or a clone? Most APM2.5 clones are referred to as APM2.5.2.
TCIII Developer

I’m Using APM 2.5.2 board and I´m connecting via USB. I´ve uploaded the firmware for Arducopter V3.0.1.
After install every time I tried to connect with Mavlink I get the error message “No HeatBeat Packet Received”. I´ve attached an image from the error.
I can connect via Terminal, but if I trie to do any config it will stop.

My Ardupilot is a 3DR, with 3DR GPS and 3DR telemetry.

I just ran into the same problem. In my case, the USB hub was not providing enough power.

I connected the USB connector directly to the computer and it worked.