Can not connect to com port and detect board type

I installed Mission Planner on another computer and need help with the drivers. When I click on the COM port box I get a list of port numbers but no names. My other computer it says Arduino MEGA 2560 after the COM number. If I select the correct port it will link to the board ok.

The problems is that I can’t update firmware because I get the message:

“Can not connect to com port and detect board type”

I attempted to manually update the driver but it did no good. I need the procedure for updating the driver. This is for Windows XP. I have APM 2 and 2.5.

I just tested the Terminal Mode and that works correctly. So it’s only a firmware update problem.


I had exactly the same issue using Windows 7. Had to install the new firmware using a friends computer.
After the firmware update Mission Planner works fine, but still doesn’t list the Arduino board in the com port drop down menu. It sees the relevant com port number and connects successfully, but won’t update the firmware.
Would be great to get this resolved…

I updated to the latest driver and no change. I am beginning to think it’s a Mission Planner problem. I think it’s trying to validate the board type but that function does not work correct on all hardware platforms.


I tried installing APM Planner 2 and it works. That version is very slow and has several bugs so I won’t use it flying. Looks like it will be a while before that version is ready for general use.

Anyway that narrows it down to a definite bug in the current Mission Planner. Apparently there is some hardware that it’s just not compatible with.