Can Not Arm Because RTL_ALT Above Range Finder Max.Range

Hello gentlemen, I just installed TF Mini on my Quad copter (that was flying well before) to measure Altitude. It work as it shows altitude on the Mission Planer. However the copter can not arm because of above issue:
“Prearm : RTL_ALT Above Range Finder Max.Range”. I set max.range is 5.5m, and RTL_ALT is 15m.

Firmware is copter 4.03. Matek765
Range Finder : Benewake TF mini nstalled on Serial 4.

For temporary testing only I set “ARM” parameter to 0 (zero), so that the Copter will ignore any pre conditioin. I can arm the copter with this setting.
But I think there is a better solution for this condition.

I also need advice what number should I set for the Scaling parameter (RNGFND1_SCALING) ? I just set 1 for scaling as I read from previous thread. Is this correct only for Benewake TF miini? How about for TF02 Pro ?? And also TF03 ???

I need advice from expert here (Patrick pppoirer, Tridge,rmackay9,Dave David, and others) how to solve r this problem.
Another question here is, why I can not find the parameter “RNGFND_LANDING” on the FW 4.03 ?? I saw this parameter setting from previous thread.

I also need advice how the best procedure to calibrate the Benewake TF mini, TF02 pro and TF03 ??
Thank you for any comments/advice.

Here is my parameter file:
ParamHA680_Initial2.param (20.2 KB)

Here is my screen shot :slight_smile:

Hello guys,
So far I can not resolve this problem. Anybody can help? @rmackay9, @ppoirier, any advice for this problem? I hope FW 4.10 can resolve this oro lem…Tks.

Hi Tony,

So the issue is that the vehicle has been configured to RTL using an alt above terrain (using the rangefinder) but the rangefinder has a range that is shorter than the desired return altitude (15m).

My guess is that you don’t actually want it to follow the terrain when RTLing, and you’re happy for it to just return at 15 above home. If so just change rtl-alt-type parameter back to 0 (I think you must have changed it to 1 at some point).

1 Like

Hi @rmackay9,

Thank you for your quick response.
I think I need to clarify .
Logically, for safety reason, I will always set the RTL_ALT much higher then max. range of the range finder. And I set “TERRAIN ENABLE” to be 1, because I want it to follow the terrain (for safety reason).

Sorry, why do you suggest to change RTL_ALT_TYPE parameter to 0 (That means to disable TERRAIN following)?? This is unsafe condition and I don’t want it to happen.
Do I misunderstood about meaning of RTL_ALT_TYPE ??
So, If I change RTL_ALT_TYPE to be 0, what will happen?
What do you mean by saying that , I have to change RTL_ALT_TYPE to 1 at some point ??
I assume this RTL may happen when I lost contact with the drone, so impossible to change any parameter during RTL, while it is flying over hills (therefore I need to enable the terrain following).
Thank you

I huess SmartRTL could be invoke, providing you stay within lidar range. Problem is when you hit reflective ground (read water) making the range going bad.

Hi @ppoirier @rmackay9,
Thank you for your suggestion, but I have simple question. What is the function of this parameter:
RTL_ALT_TYPE = 0 ? My assumption is this will Disable Terrain following during RTL…But I need confirmation if this assumption is correct.
Another question is why I can not arm, if RTL_ALT HIGHER than max.range of the Range finder? Is this really True in all condition, even though my altitude source is Barometer??
Any comments is appreciated.

For this, sometimes you need to look at the code, it is not so difficult as you can go through readings comments and applying logic. This is the best way to open a request for change as you can better explain the requirements

Here are RTL_ALT_TYPE definition

And here some insight at RTL_ALT


If you want to disable the use of the range finder for terrain following in missions and RTL then you can set the WPNAV_RFND_USE parameter to zero.

It’s probably obvious but just in case, it is not possible for a vehicle to fly at 15m above the terrain using a rangefinder with a range that is less than 15m range. This is what the arming message is warning about.

I know this is an old topic but the same prearm-check-message occured to me lately.

Thanks @rmackay9 for pointing out WPNAV_RFND_USE and I will use it that way for now.
In my case we have the downward facing rangefinder to determine the height of the UAV above the object underneath for emergency situations (e.g. landing at a rally point to ensure the slow landing speed or if a manned aircraft approaches to descend to a specific altitude above the object beneath the UAV).

But for RTL I would really like to use the terrain following feature using the elevation data uploaded prior to flight and not the downward facing rangefinder. We often fly in hilly or mountainous regions and therefor the UAV could easily reach altitudes greater than 120m above ground in RTL mode when not using terrain following. Our set RTL altitude though is greater than the max. range of the rangefinder. With the WPNAV_RFND_USE parameter I can achieve that.

There might be a scenario where we want to use the rangefinder for terrain following during mission at let’s say 20m AGL, but still want to use the elevation data for RTL at 80m AGL.
As far as I understand, this wouldn’t be possible to achieve at the moment. Or am I wrong?

Thanks in advance

Hi @sidux,

That’s right, we don’t allow mixing of range finder and terrain database altitudes. There’s an item on the to-do list here along with some suggestions of how we could do it. It’s not straight forward though because the two are really quite different. The terrain database doesn’t include trees and buildings while a rangefinder would see these.

Taking a step back, my guess is that what you’re looking for is actually object avoidance of the ground using the terrain database and rangefinder. This is actually a little different than “surface tracking” and “terrain following” because for these two features the user wants the vehicle to fly at the specified alt above the terrain (for spraying crops, taking pictures at a precise altitude, etc).