Can connect to APM but not exchange data

I have a Nexus 7 with Android 4.4.2 and Droidplanner 1.2 installed. This is connected cia a USB-OTG cable to the ATMega 2.6. I can connect to the APM but it wiats indefinitely for data. What could be wrong? I did perform some tests as to see where the error could be.

  1. I used OTG trouble shooter to see whether I had an OTG connection. It says it has USB host support and OTG is detected. When I connect my SD card reader it detects a USB device in Linux and Android. It does not detect Linux and Android when I connect to APM. I assume this is normal as it tries to detect storage devices.
  2. MavLinkHub detects two Arduino Mega 2560 devices: one with long hexcode@16033 and the second with the same long Hexcode@16034. When I connect to the first one MavLinkHub crashes, the second Arduino Mega connects well. However, it also waits indefinitely for data.
  3. Droidplanner 2 connects but reports that the datalink is lost and I should check the connection

I am not sure what is wrong. Could someone help me out?

Thanks in advance!


I have that as well. It’s connected at %100 but often says it lost connection. However mine seems to resolve itself after a few minutes I have no idea why. Just out of curiosity have you tried waiting a minute or two?

I did now and it works! It is important to check and recheck all settings, plug everything in, indeed wait several minutes, plug it out and in again and wow, it works for both 1.2 and 2.0. This is great stuf, I’m very impressed!

NavLinkHub keeps waiting, I don’t need it anyways so I’ll uninstall it.

Thanks a lot, you really helped me out!

Please, remember to check the solved button for others known that tis topic havea a solution :wink:

Ah, I had not seen that. Thanks for the hint.