Camera Gimbal greyed out

Hello all,

I am trying to get my Tarot T3D Gimbal setup to be able to control yaw and pitch with my TX and at some point controlled by an Auto Mission on my quad. The Camera Gimbal GUI settings in optional hardware are greyed out.
Hardware/Software:
Pixhawk 5x
Arducopter 4.3.3
Mission Planner 1.3.79

I have tried to configure the gimbal in the parameters and have tried MNT1_TYPE 1 & 7 and neither work. I have my RC10 and RC11 to control Mount1Yaw and Mount1Pitch respectively. I have Servo13 & Servo14 to Mount1Yaw and Mount1Pitch. Maybe Im missing something but the fact that mission planner isnt allowing me to configure (still greyed out) has me doubting. The Camera Gimbal GUI does show the proper Servo13 & 14 but not the RC control channel or Mount Type. I did notice when I adjust the slider on my TX for the Pitch it does respond a tiny bit (MAYBE a degree). Im sure I forgot to add something but anyway I appreciate the help. I saw previously there were issues due to mission planner not understanding multiple mounts but I configured Mount1 in the parameters.

Eric




Hi @Eric_Brune,

The greyed out mission planner is a known issue (see issue here). I hope we will eventually get this page updated to use the new 4.3 parameters.

… until this is done I’m afraid the only solution is to directly update the MNT1_ parameters using a ground stations Full Parameter List (or Full Parameter Tree).

It might be good to provide an onboard log so we can see more details. That could require setting LOG_DISARMED = 1 so that a log is produced even when the autopilot is disarmed.

Thank you very much for looking into this. I will continue to investigate as well.

I armed the quad in stabilize, ran up the motors a bit then moved the controls on the TX that I am trying to use to adjust the gimbal…

Log file…
https://drive.google.com/file/d/1pS_prrqjP9Urs3VlYqXxIfeU4OtEQNW4/view?usp=sharing

My issue was solved. I had the pixhawk servo channels set in the tarot gimbal configurator as I was originally going to use the gimbal via sbus. I changed the tarot configurator settings back to conventional (pwm) and never changed the channels back to 1 and 2.

Mission Planner GUI stilled greyed out but I have the gimbal working correctly via the MNT parameters.

1 Like

Have you figured out how to adjust the default angle of each axis (only concerned about tilt/pitch tbh). Using the MNT1 parameters, I’ve got the servo tilting as the drone tilts…but its pointing too far down. There’s a “Neutral Angles” in the “Camera Gimbal” tab, but as aforementioned: it’s greyed out.

How can I set, say, RC Channel 7 (potentiometer on my TX) to control the pitch manually AND have it hold that angle relative to earth still. I tried setting RC7 to 213 (MNT1 Pitch) and RC9 to 163 (Mount Lock) to enable it…but it doesn’t work.

I can only control the servo manually if I completely disable the MNT by setting Servo9 to RCIN7.

Anyone know a solution?

@Caleb_Dollarhide,

The RC9 setting of 163 (Mount Lock) shouldn’t be required. This only affect yaw so maybe we should rename it.

The RC7 setting of 213 (MNT1_Pitch) is the key. But could you check that the parameter values below? The values don’t need to be exact but the important thing is that RC7_TRIM is mid-way between MIN and MAX.

  • RC7_MIN = 1000
  • RC7_MAX = 2000
  • RC7_TRIM = 1500

If this doesn’t help perhaps post an onboard log.

What would be the parameter to update in the full parameter list for enabling “Stabalise Titlt” (button on the greyed out gimbal page)? Note that I’m using a servo gibmal. Thanks

Hi @setho,

Pitch is always stabilized so there’s no need to set a parameter for this. If you find that the gimbal is not stabilizing then the issue could be that it is in Retracted or Neutral mode.

You’ve probably already seen this servo gimbal setup wiki page but just in case…

… and we also have this wiki page which describes how to control the gimbal using RC or the ground station.

1 Like

Hi @rmackay9 Im running simulation on hardware ArduCopter v4.5.0 dev

I cannot find MNT parameters, is there a way to enable them?

Thanks!

I found that the gimbal parameters cannot be found in versions higher than 4.3. Have you solved this problem now?

They can be found in the Full Parameter List.

Well, I’ve figured out what’s going on since I use a MATEK F405 WING. Therefore, after version 4.4, due to insufficient flash, the gimbal part was deleted, so it cannot be found in the parameter table:)