Servers by jDrones

calibration problem with esc

I am facing a problem with Pixhawk Board running Ardurover stack, recently i upgraded my transmitter to Flysky Noble. When I hold the throttle at max, Motor 1 starts spinning motor 2 is idle But, when i return the throttle to Zero position the 2nd Motor goes into calibration mode (3 beeps) and 2nd motor starts to spin at (0 Throttle).
Your suggestions will be helpful.
-Thankyou

Hi @Arjun_Ramanujam, sorry for the slow response.

We can give more info if you can download and post a dataflash log file but without that we can probably guess that it’s one of these issues:

The output range is set incorrectly. Try checking if SERVO1_TRIM and/or SERVO3_TRIM is set to some value far from 1500. After changing this it is a good idea to use the motor test to check that each motor is spinning properly.

The RC input is setup incorrectly:

  • Open the RC calibration screen and check the green bars are moving in the same direction as the physical sticks. In particular the Roll (channel1, used for steering) and Throttle (channel 3) are moving correctly.
  • Check that the RC1_TRIM and RC3_TRIM are set to about 1500 (not 1000)
  • Ensure PILOT_STEER_TYPE parameter is set to zero
Servers by jDrones