Calibration Issue - Skywalker 80a

Hi there

For pass few day I’m trying to deal with above problem. Tried different way to do calibration, in each same issue reaper. Motor goes straight to regular boot. Main thing is throttle calibration because each motor start differently.

Can anyone have some ideas pls… cos I’m loosing my mind.

ESC: skywalker 80a
RC: tbs crossfire

ArduPlane V4.1.7

Did you try the traditional calibration directly with the Rx PWM?

Good luck.

Waiting for right Rx. Will see.

Thanks for tip…


I already faced troubles with this ESC, because it has lots of configurable itens that are acessed in the same way you perform ESC calibration.

For me, only direct Rx PWM worked.

Here is the datasheet of this ESC. Notice that you have lots of options to access and maybe ardupilot calibration is not accessing the right option at time.

SkywalkerV2.pdf (343.9 KB)

Thanks for your advise :slight_smile:

Can I use tbs diversity nano for direct Rx PWM?
If Yes, Does anyone of you guys knows how to wire it properly? :slight_smile:

I’m watting for new Archer r6 Access to swap tbs setup. But If it is possible to do it with tbs that would be great news.

Personally, the only thing you need to change is to turn on the Brake. Everything else can stay as default.

Good luck.

Will do that if I will get them to calibrate.

Main issue is that they not spooling at the same throttle position. In Vtol Mode it is acceptable but i plane mode the gap is quite huge. As I can assume min and max position must be calibrate but I can not get to that point :frowning:

Can Mavlink be the issue?

That’s the main purpose of the calibration process, is to determine its max and min endpoints. This video is an old basic one with explanation. Once you get the endpoints calibrated, then go back in and program the brake.

Good luck.

Direct Tx calibration didn’t work for you?

Hi there

Maybe I’m doing something wrong. Might be :wink: Trying to fix someone else build.

I’ve connected Tbs Crossfire Diversity Nano straight to the ESC:

Tbs CH3 → Signal ESC
Tbs + & - → + & - ESC

Nothing same thing. No respond. Boot Sound and after that one single beep every 2 second or so.
Using Orange Cube + MavLink communication with all channels works fine but no calibration or min max throttle setup :frowning:

Going out of my mind how to solve this.

Any idea?

This indicate that your ESC is receiving no PWM signal. Are you sure that you are outputting something by your Rx? The GND used for signal and power are the same? These could be the problem.

Ok… that might be the dumbest question :slight_smile: What is the easiest way to check if my RX is sending proper signal?

And if pls explain this cos might be I’ve done something wrong… I know, nob question. But planes and ardupilot a news to me so… :wink: Rx GND to ESC GND, Rx + → ESC +, Rx Signal → ESC Signal.

In most common ESCs, the ground that is placed in the 3-way signal-connector must be connected to the ground you are powering your ESC up by the power wires. So, if you are using an external battery to supply your ESC and using for instance a second battery to power up your Rx, maybe it will not work. So, make sure you are powering everything up from the same battery.

Do you have some servo motors? Try to command a servo instead of the ESC and see if it works in the proper way. I would say it is the simplest way to verify it.

Hi :slight_smile:

Let the battle continue.

That might be the case. Cos not event the new build are starting the calibration.
As I sad that is someone else build and I’m trying to get my head around it. As I can see it uses mavLink, but the wiring might be off. Its is connected to OrangeCube both ways - With RC_IN and Telem1 (Output CH3 - Sbus, CH7 & 9 - mavLink). As I can see on Painless360 tutorial it should uses only telem1.

I can arm it fly with it ale that stuff but because the new esc not calibrate same way as the old one I unflyable :frowning:

Finally got it calibrated. Had to change protocols on according channel to make it work.

But now I’m getting rapid beep of motors (The throttle stick is not in the
bottom (lowest) position) but only after arming it witch OrangeCube safety switch :frowning: I have programmed each ESC separately, ,might be the case that stick was not on it extremes?

I can deal with above by fine tuning endpoints, but then in VTOL mode motor spins after arming :frowning:
any ideas

Sorry for multiple posts :slight_smile: but wanted to share every step with community…

I got it sorted out… finally.

Had to lower Q_SPIN_MIN to stop motor spin after arming.

All the rest is working fine…

Thanks all of you guys for great inputs :slight_smile:
Happy Flying

1 Like