Calibrate Level Error: The Command Failed to Execute

Hello,

I keep having troubles to calibrate level of my plane in initial setup tab. Once i setup level of the plane and hit the button i keep having an error "Calibrate Level Error: The Command Failed to Execute”.
It happens all the time regardless of plane being armed or not.
I did calibrate accelerometer right before but it does not help.
I’m connecting plane to pc via USB cable

Matek h743-wing flight controller board
Arduplane 4.0.8
Mission planner 1.3.7

I appreciate any suggestions and support.
Maciej

I’ve found this can be due to a max angle error. For example, my controller was mounted at a 15degree roll offset, and I got the same error. When I leveled it better (<< 15deg), the level command worked.

@Maciek_S Did you get this to work? I am having the exact same problem with my Matek H743-slim running the latest Arducopter build, latest Mission Planner.

The accelerometer calibration succeeds after it goes through the several steps required (turn FC on the left side, right side, etc), but the level calibration continues to fail with the message: “The Command Failed to Execute”.

Here are the messages I see in the Messages tab afterwards:

5/23/2021 12:31:09 PM : PreArm: Internal errors 0x1000000 l:168 imu_reset
5/23/2021 12:31:09 PM : PreArm: Battery 1 low voltage failsafe
5/23/2021 12:31:09 PM : PreArm: Compass not healthy
5/23/2021 12:31:09 PM : PreArm: Gyros not healthy
5/23/2021 12:31:09 PM : PreArm: Throttle below Failsafe

The FC is connected to my laptop via USB (COM10 with MAVLink), and it’s “naked”, nothing else connected to it yet.

Any suggestions for what to try next would be greatly appreciated…

When you did the calibration did you have the compass/GPS module connected? If not, connect that and try again.

Thanks @Allister. Yes, I have connected a BN-880 GPS+compass as well. I am acquiring satellites, and the compass heading shows up in MP, but the Level calibration continues to fail with the same unhelpful error message: “Command Failed to Execute”.

Looks like pretty much everything else in the “Mandatory Hardware” section in MP can be configured with a bit of patience, but the Level calibration doesn’t work.

The FC is lying flat on the workbench with the peripherals connected during this operation, and everything is standing still with no vibrations, no movement.

This is truly puzzling to me. I have a lot of experience with KISS, BetaFlight, and CleanFlight before that. This calibration step was always a quick click for me in KISS/BF/CF, and it always succeeded. I am not sure under what circumstances it can ever fail??? Is it a matter of writing some data back to the FC via MAVLink, and that’s possibly failing? (BF/KISS/CF do not use MavLink for communication with the FC afaik).

Is there some log where I can do some digging and see if there are any relevant/useful error messages that may help elucidate this mystery?

It’s usually a pretty painless process with AP as well.

Is the compass pointed in the same direction as the FC? When you move the FC are you moving the compass as well?

It took me a while to put everything together so I could answer these questions. Yes, they are pointing in the right direction. The compass is integrated into the Beitian BN-880 GPS unit, and it’s aligned with the direction of the FC, which is pointing forward. When I move the quad, both of them move at the same time and the resulting direction lines in Mission Planner point the same way. Yet the “level calibration” always results in an error: “The Command Failed to Execute”.

Any other ideas, or things that I could try?

Thank you in advance.

Could it be that under Config, Full Parameter list, AHRS_ORIENTATION was set wrong? I set that parameter back to 0 (none) and then I was able to Calibrate level on my Matek F405 Wing.

No, unfortunately not in general. I worked once or two but it was after 1000 of reflashes etc. so cannot really tell what worked out. Now, when I switched to another plane i keep having similar issue - cannot calibrate the level.

Thanks - i will try it out, however i do not use a compass.

Hi @Maciek_S,

Just ran into the same issue today while calibrating a small (<1kg) simple FPV plane with GPS but no compass; I’m running Plane 4.1.2 and the FC is an omnibus F4 Pro V2.

The FC is installed Yaw’ed (if that’s word) 270deg (AHRS_ORIENTATION = 6) and not super flat from a Roll perspective.

Similar to you I was getting the message “The Command Failed to Execute” while trying to calibrate. The calibration was working on the bench a couple of weeks ago.

I’ve updated Mission Planner to “Beta Updates” - v1.3.75.1 - and now ‘Calibrate Level’ works; also there’s a new ‘Simple Accel Cal’ option that also works.

Hope that helps.

Cheers

Thanks for letting me know, for some time I switched to simple planes with no FC board.

sob., 13 lis 2021, 21:20 użytkownik Charles Young via ArduPilot Discourse <noreply@ardupilot.org> napisał:

I am still facing the issue with APM 2.8 board.

Just worried as I don’t want to loose this board and in India things are pretty bad when it comes to importing new stuff for aerial vehicles.

Can someone help me please! :roll_eyes:

get an five years earlier version of Mission Planner, that will work,

1 Like

as you said installed a 1.3.69 edition of the MP and it has seem to solved the issue!

thank you very much! :slight_smile: