Building APMRover on Windows

I’ve downloaded the latest code, and installed the toolchain.

I follow the directions - make configure, make clean, make px4-v2 from within APMrover2.

I end up with:

$ make px4-v2 HAL_BOARD=HAL_BOARD_PX4 TOOLCHAIN=NATIVE EXTRAFLAGS=-DGIT_VERSION="312a2fc8" -DN UTTX_GIT_VERSION="ed45e813" -DPX4_GIT_VERSION="f05f42cc" make[1]: Entering directory `/c/Users/MRoberts/Documents/GitHub/PX4Firmwa re' %% Configuring NuttX for px4fmu-v1 include/arch already exists but is not a symbolic link make[2]: *** [clean_context] Error 1 make[1]: *** [/c/Users/MRoberts/Documents/GitHub/PX4Firmware/Archives/px4 fmu-v1.export] Error 2 make[1]: Leaving directory `/c/Users/MRoberts/Documents/GitHub/PX4Firmwar e' make: *** [/c/Users/MRoberts/Documents/GitHub/PX4Firmware/Archives/px4fmu -v2.export] Error 2

Any hints? I re-cloned the latest ardupilot, PX4Firmware and PX4NuttX from github just before I ran it.

1 Like

OK, grabbed everything again.

I DIDN’T do a “make px4-clean” and it got a lot further:

%%%% Building px4fmu-v2_APM in /c/Users/mroberts/Documents/GitHub/PX4Firm
%  PX4_BASE            = /c/Users/mroberts/Documents/GitHub/PX4Firmware/
%  GIT_DESC            = 312a2fc8dc20176a1dfb8fb494c17f64f7a0b9e5
%  CONFIG              = px4fmu-v2_APM
%  BOARD               = px4fmu-v2
%  WORK_DIR            = /c/Users/mroberts/Documents/GitHub/PX4Firmware/B
%  NUTTX_EXPORT_DIR    = /c/Users/mroberts/Documents/GitHub/PX4Firmware/B
%  NUTTX_CONFIG_HEADER = /c/Users/mroberts/Documents/GitHub/PX4Firmware/B
make[2]: Entering directory `/c/Users/mroberts/Documents/GitHub/PX4Firmwa
 *** Can't find module(s): modules/libtomcrypt modules/libtomfastmath systemcmds
/auth.  Stop.
make[2]: Leaving directory `/c/Users/mroberts/Documents/GitHub/PX4Firmwar
make[1]: *** [/c/Users/mroberts/Documents/GitHub/PX4Firmware/Build/px4fmu] Error 2
make[1]: Leaving directory `/c/Users/mroberts/Documents/GitHub/ardupilot'

make: *** [px4-v2] Error 2

*** Can't find module(s): modules/libtomcrypt modules/libtomfastmath systemcmds /auth. Stop.

At least a couple of these seem to be recently added. Is it possible they’re not in the v05 toolchain for Windows?

Has anyone successfully compiled in Windows?

Have you tried Atmel Studio 6.2. See here: … ual-micro/

Just completed the tests. The link and name may change as it works with the free Atmel Studio and the site is being updated.
If the link does not work, just go to the developers area and follow links to building APM.


Does that Atmel Studio work for Pixhawk?

Any resolution to this?

I am having the same problem

I had this same problem but I managed to resolve it by deleting my PX4NuttX directory and cloning it again from