Building a Tarot 450 V2 FBL with APM 2.6! Help Needed!

Hi everyone!

I just bought a Tarot 450 V2 FBL Traditional Helicopter and I bought the following:
APM 2.6
Telemetry 433 Mhz
Vibration Board
Power Module
Tarot 450 V2 FBL Kit ( Assembled it already )
Turnigy Helidrive SK3 T450-1700KV
Turnigy Plush - 40A

Turnigy TGY-90S X 3 of them
Savox Tail Servo

Custom RC Batteries I made working in series with Specs:
11.1V at 53ah 0.5C Discharge each
giving me 22.2V when working in series to power the Brushless motor.

I have a joystick to control it and I have downloaded and installed in Windows :
Mission Planner
APM Planner 2.0

This is my first traditional helicopter built and I would really appreciate your feedback
regarding the configuration for the APM 2.6 and any ideas on the possible problems
that you have found while attempting this build.

I hope that after the trad heli works to make quite a few hardware modifications on the
APM 2.6 and add some software modifications for some extra functions on the firmware
and software, which include motor failure autolanding and communications over Delay
Tolerant Networks with which I have worked in the past.

Kind Regards!

I am using APM Planner 2.0 with Linux.
Ok so the problem I am having is with the external Compass.
As I connect the APM with the APM Planner 2.0
I can get connection with 7-8 satellites the Horizon in the APM Planner works, but I am
having problem with the compass. I try to configure it. I select 3DR/GPS it automatically
selects Roll 180. But it doesn’t seem to work neither with calibration. So I choose the internal
and Gives None 0 and I have selected the Enable Compass and Auto Declination and I disconnect
the external Compass then the software seems to get correct values. Is there a way to get the
external compass working ? I might have made a mistake. I see the GPS working just fine getting about 7-8 satellites with not much signal. Also which one you find better in terms of usability for the traditional heli
the APM Planner or the Mission Planner ?

Any ideas are always welcome.

Thank you in advance.

Problems Problems… …

When I try to upload the firmware using the Mission Planner, it gets uploaded but it gives
a random verification error, cannot verify and gets stuck !
Anyone had this problem before ? How do I fix it ?
I use the COM3 - Arduino

Then I tried to do the same thing through Linux with APM Planner 2.0 and seems to work ?!


The Compass external or OnBoard cannot be configured. I might as well build my own Compass/GPS
this is frustrating.

Any input from the developers would be great.

Thank you in advance for any help.


OK ! I got the compass and accelerometers calibrated successfully.

I also connected and calibrated the 6-CH RC.

It works


the motor or the ESC make a beep sound every 2 seconds when I connect the motor.

Anyone has an idea for it ?

Thank you all in advance.

OK motors works

hahahahahahaha!!! :smiley:

So I am connecting something wrong :blush:

This is The_Aviator’s odysee hehehehe :laughing:

ok so I need to figure out where to connect the servos and rc channels from my Rx :laughing:

Current Servo Location :

Rudder Servo ---------> APM 2.6 Output 4
Level Rear Servo -----> APM 2.6 Output 3
Front Right Servo ----> APM 2.6 Output 2
Front Left Servo ------> APM 2.6 Output 1

The receiver is the

E-Fly 2.4 GHz DSM
6-Channel Receiver

and has the following outputs

1 --> AILE
2 --> ELEV
3 --> THRO
4 --> RUDD
5 --> GEAR
6 --> AUX1
7 --> BATT

Soooo !! :mrgreen:

To make the ESC work I connected

3 --> THRO with the ESC
7 --> BATT with APM only the Black and Red so I give it P0W3R :laughing:

and then music started playing from my ESC and I started jamming with my guitar and the Tx Sticks and the motor started working yeahhhh :smiley:

Now the Connections for the Rx on the APM Outputs

I tried the following
1 --> AILE Output Pin --> 1
2 --> ELEV Output Pin --> 2
3 --> THRO Output Pin --> 3
4 --> RUDD Output Pin --> 4
5 --> GEAR Output Pin --> 5
6 --> AUX1 Output Pin --> 6
7 --> BATT

At this point it works but since the ESC is not connected the motor cannot work BUMMER!


I will connect the ESC in the APM input 7 and I will come back to continue my log file in this thread as there is not a soul reading it hahahah :laughing:

I will see ME in a bit :ugeek:

I’M BACK !!! :ugeek:

So … it looks like the connections are looking good in the Mission Planner but even though I have the same connections in the INPUT of the APM for the servos the movements are Wrong :question: :exclamation: :cry:

If there is anyone out there that can simply take a picture or write down the connection they made to
their Traditional Heli for the Servos on the APM 2.6 Inputs would be great as I am having a feeling that
the wiki is outdated.

ok I will try some trial and error and searching online I might find something.

See me in a bit ! :ugeek:

OK so I think there must be something with the PID parameters.

I noticed that when it loads it is giving the following parameters file


Is this good for Traditional Helis ?