Servers by jDrones

Build Environment - waf

Hi everyone,

i am new on ardupilot and started to work through the tutorial on ardupilot.org.

When setting up the building environment on my Ubuntu 20.04 following the instructions on
https://ardupilot.org/dev/docs/building-setup-linux.html
it seems i did fail with setting up the gcc-arm cross-compiler. In particular, when trying to configure waf for my board, i get an error saying “Could not find the program [‘arm-none-eabi-ar’]” (see below).

gnu make, gawk and libc6-i386 are installed.
I downloaded and unzipped gcc-arm-none-eabi-6-2017-q2-update-linux.tar.bz2, and added the following line to the .bashrc file (following the instruction, and absolutel not sure what i am doing here)
export PATH=$PATH:~/ardupilot/gcc-arm-none-eabi-6-2017-q2/bin

It seems I missed something very basic, but cannot figure it out. Anybody out there who has an idea?

thanks in advance
Christian

dunduk@dunduk-H97-D3H:~/ardupilot$ ./waf configure --board PH4-mini
Setting top to : /home/dunduk/ardupilot
Setting out to : /home/dunduk/ardupilot/build
Autoconfiguration : enabled
Setting board to : PH4-mini
Using toolchain : arm-none-eabi
Could not find the program [‘arm-none-eabi-ar’]
(complete log in /home/dunduk/ardupilot/build/config.log)

Servers by jDrones