Build 1.3.5 prefetching map Issues

Mission Planner Build 1.3.5 prefetching map Issues

Trying to load a map in mission planner seems to take a really long time. I loaded a map that took 36 hours to load and it’s not a very large area.

I am holding down the ALT key while dragging the area that I want to get. From there I right click and select prefetch map. Loading seems to go pretty fast at first then seems to really slow down.

Thing I have tried:
Uninstalling and reinstalling Mission Planner.
Multiple computers
Different wireless networks
Removing all Mission Planner data from registry

Anyone else having this issue?

Is there a fix or an update to mission planner that fixes the issue?

How big is the area? Do you really need the most zoomed in tiles? Can you tell us at which level it seems to noticably slow? Send a screen grab, if you use the Google Hybrid that is a lot of data.

Bill thank you for the fast reply,

I am doing a map that is the size of around 250 x 250 meters.

As far as the tiles go i’m usually around 17 to 19 zoom.

It really slows down around 22- 23 zoom.

Is there a way to not have it load all the different zoom levels?

I have been using mission planner for 2 years now with no issues so I am just wondering what changed?

I loaded a 1 year old mission planner and the Google hybrid map loaded in about 2 minutes.

Thank you,

If you hit ESC twice it stops fetching.

If I stop fetching then wont my map not be complete?

The area will be covered, but will not be as detailed. You asked about stopping at lower zoom levels, that’s how you do it.

A screen grab would help, and maybe some info like your internet connection speed (there are lots of online free speed tests)

Using I am getting 43 down and 11 up so pretty fast.

Here is a photo of the slow upload. disregard the way points those were an accident.

google does throttle as well

Yup…I can second that.

I’m also trying to prefetch a very small area and its rediculously slow.
An area the size of 3 football fields, took 4 hours to complete.
After level 22, it crawls.

Internet connection is 25dwn/10up.

I tried this on 3 different PCs and laptops.
Exactly the same thing. All with v3.1.7 of MP.

Also tried this from a couple different locations, with different internet speeds.
Doesn’t seem to make any difference.

So either Google is throttling or there’s an issue with MP.

ok…just ran some more tests.

I tried the major maps, Bing, Yahoo, Google.
All prefetch at the same speed.
So that leaves the common denominator.

The issue is with Mission Planner.

I haven’t downgraded to an older version of MP yet.
Maybe I’ll try that next, see if there’s any difference.

you do realize that with each zoom level the number of images to download goes up

I just delete out all the cached maps from Mission Planner and then fire it up. Go to the area I plan to fly and copy the newly created folders to my tablet adding the .nomedia tag to each subfolder so they don’t show up in my photo viewer. Very fast this way.