Bug with mission planner 1.3.43

I updated to mission planner 1.3.43 a couple of days ago and noticed two bugs.

1st, the connection is no longer remembered and always defaults to UDP when started instead of the last remembered.

2nd The actions tab only now shows Auto, Loiter and RTL buttons and nothing else!

3rd The test all motors in sequence on the motor test page of optional items doesn’t do anything other than start motor A.

Try the latest Beta it will definitely fix the first issue

Thanks. There used to be a way of reporting bugs, but that seems to have disappeared.

I see version 1.3.44 doesn’t address any of these bugs as they are still present. Is there somewhere to report bugs to be rectified anymore?

Same issue with both version using the Pixhawk 2. Kinda ridiculous to remove functionality. I’m rolling back to a previous version.

goto MP settings and change layout to advanced.

Thanks Michael, that brought the missing items back :slight_smile: Any idea’s about the other issues, defaulting to UDP and not the last connection and the motor test issue?

please update to latest MP.
I released a new version that will resolve the udp issue.
as for motor test. you are the only one reporting this issue. so I’m not sure

I find that there is no way I can use joysticks with MP
The game controller is found, it lets me choose controls, but it will not save the setup.

I have tried the various work-arounds mentioned in other forums (copying files, etc.) Nothing seems to work. The joystick that I just bought is worthless until this is fixed or someone has a solid work-around. I’m running Win10/64.

can you please detail your process?

one thing I will say, is connect to your vehicle before you open the joystick screen. see if that helps

Somehow, some way, I got it to work. I will have to go back and retrace my steps to see if I can duplicate my success.
But… the Logitech joystick mentioned is NOT optimal for mutirotors. Both sticks return to center via a spring-loaded disk. It is disconcerting to have a multirotor idling on the ground and when you let go of the throttle, it snaps to mid-point and takes off. It is actually dangerous.

Although it was far from easy, I hacked the joystick and now it doesn’t auto-center. Lots of desoldering and X-Acto knife work.

I’m setting up redundant control methods for my craft. Mission Planner would be a really good backup to a Futaba radio if it had a better method of joystick input. It would also be great if it didn’t reload all parameters on reconnect when connecting to the same craft using a different protocol. I use both RFD900 radio and 4G for telemetry, so I switch back and forth between COMx and tcp protocols while the craft is in the air.

I’ll try to set up the joystick again and see if I can find the exact steps that work - and then I’ll let everyone know.

Another problem with the Logitech joysticks - the joystick movement is limited to a circular motion. In other words, you can’t give maximum yaw and minimum throttle, or maximum pitch and maximum roll at the same time. As the joysticks move off center (say) vertically, their horizontal movement is restricted. Ordinary R/C controllers have a “square” pattern, not a round one.

These faults make the Logitech game controller nearly useless for multirotor use in my opinion. We need a better solution.

I’m still trying to get MP to save settings. Maybe I’m doing something wrong, but nothing I do seems to work.
The joystick is recognized, but when I save the settings and quit and restart MP, the settings are gone.

I have tried the following:

When NOT connected to a PIxHawk or APM:
Choosing ENABLE first, then detecting the sticks and then SAVE
Not choosing ENABLE and detecting the sticks and then SAVE

When CONNECTED to a PixHawk or APM
Choosing ENABLE first, then detecting the sticks and then SAVE
Not choosing ENABLE and detecting the sticks and then SAVE

Closing MP and restarting.

None of the methods above work. When I restart MP the joystick settings are gone.

Being able to use the joysticks are very important to me, since I want to use MP as the ONLY interface to my aircraft.
I would try a beta/unreleased version - anything.

you are using the latest version?

also could you please upload your c:\programdata\mission planner\missionplanner.log file

this should show where its trying to save and load the file from

I did get things to work, but I now have another issue: I found a controller that has 6 Analog channels, but for some reason it seems that all the simulator controllers have a very narrow range. That is, minimum pulsewidth is around 1150uSec while maximum pulsewidth is 1700-1750uSec. My goal is to have the controller attached to Mission Planner mimic my other (2.4Ghz) controllers.
Is there a way to take the PWM input as received by MP and multiply it by some value (say 1.3) and add an offset? That way, MP could adapt itself to a wider variety of controllers.
Alternately, if someone would give me some hints as to where the joystick input routines are, I could try to modify them myself.