Bug Report: Qiotek UAVCAN Airspeed Sensor no longer works with Cube Orange from Arduplane 4.1.0, 4.1.1 and 4.1.2

Hi everyone.

I’m having issues with Airspeed Sensor not working with Cube Orange. The same hardware works with Cube Black and reports airspeed correctly.

Airspeed sensor = Qiotek UAVCAN 5033
Cube Orange
Cube Black


Attached is video explaining the situation.

i have tried BRD_BOOT_DELAY too. It didnt work.
I have also found that it works with Arduplane 4.0.2 on Cube Orange but doesnt work on future updates.
I have also tested on Cube Black and other version of pixhawks Arduplane 4.1.1 and it works
On the param, I did compare with both Black and Orange, everything setup the same.
Video below shows that it works with 4.0.2

@curtisleo tagging for ref

I have also found that it works with Arduplane 4.0.9. Issue starts from 4.1.0

@tridge Do you know who’s the best to answer this?

More findings, I managed to get it working. I provided external 5V to the sensor and added BRD_BOOT_DELAY 3 seconds. Now it works on Arduplane 4.1.2. Will run more testing

@David-Amuthesan Hi, we need you to provide more information to check the cause of the issue. We have tested the ASP5300-CAN connected of Qiotek, CUAV ,Hex, and several pixhawk versions of flight controllers. At present, it seems that this issue is only on the cube orange and is limited cube on the original baseboard. Could you leave an email or skypeid? We need more information to find out the cause of the issue.

Hi Jason. My email is david@dronology.my