Bounces during Auto Land


When I use Auto Land, like RTL, the quad will touch down correctly but then lifts again, sets down, lifts again, sets down etc. It does this between 1-3 times before it will settle on the ground and reduce the power to the motors.

My Throttle stick is always low before it touches down in auto land. So that couldn’t be the problem.

I use the APM 2.6 with V3.1-rc7 firmware.
My TBS Discovery Pro is quite well tuned. I used the Auto Tune option in V3.1-rc7. I really recommend it. Also I use the V Frame setting at Mission Planner. It is a big difference to my tuning attempts.

So if anyone has an idea what causes the bouncing, I would really appreciate it a lot.


Hi Steven,
I would suggest lowering the LAND_SPEED parameter shown on this page:
It is possible that when your copter sets down, ground effect / turbulence is causing it to balloon back up and as the copter has to detect minimal movement for 1 second before it will turn off the motor, it isn’t actually realizing it has touched down until the ballooning oscillations get small enough.
Lowering the LAND_Speed parameter a bit should help because it should reduce the ballooning tendency.
The TBS is generally a fairly light and powerful copter so this kind of over correction is likely.
Best Regards,

Thanks Gary,

Today I tried to change the LAND_SPEED as you suggested.
I went all the way down to 30 m/sec but it was still bouncing. I couldn’t go lower on this because the copter was hardly declining. It took forever to get down.
I also tried to set it to 60 m/sec just to see if there is any different behaviour, but it seems no matter what the LAND_SPEED is, it is still bouncing.
It is actually not really bouncing. It’s touching down completely for, I guess close to a second, but then it the motors are speeding up again and the copter rises about 2-3 inces and gets down again and up and down 1-3 times.


Hi again,

I just thought the bouncing could have something to do with another problem I have.
When I switch to ALT HOLD or LOITER the copter is slightly fast oscillating ,almost not noticeable.
In STABILISED MODE it flies without any problems.
Today I also put instead of 9x5 props my 10x5 props on.
So I had noticeable more thrust.
Interestingly the oscillations in ALT HOLD and LOITER got worse.
Could this problem affect the bouncing problem I have ?


This is just a thought, but landings are detected by observing reduced change in altitude, it is possible when you get to the ground your prop wash might create a condition of pressure change at the baro and that is what the throttle is trying to compensate for.
If so that would be easy to see in the logs. If you look at the baro right while trying to actually land does it do anything (unlikely) right before and during that bounce period, like spike up or down a bit?

Hi Gary,

I viewed my logs and it seems that the baro parameter goes below 0 and even down to -6 when the copter touches down.
Therefore the APM thinks the copter is falling, faster than the LAND_SPEED, and increases the throttle to get back to the set LAND_SPEED which in my case is 50 m/sec.
I think this is the reason of the bouncing.
The reason why the baro goes so low on touch down is because the APM is located below the the props between the upper and the lower frame plate. Also the TBS Discovery has very short legs and sinks into the gras down to it’s lower frame plate. APM is as good as level to the ground.
So the props causing a high pressure turbulence at the baro sensor.
I think this is also causing the problems with the oscillations at ALT HOLD and LOITER as I mentioned before. Because the copter is flying the turbulences are not so strong as at landing.

Do you think there is a possibility to fix this with changing some parameters ?
If yes, what parameter would it be ?
If not I would try to eigther place the APM higher on the top frame plate and/or
make longer legs so the copter won’t sink in and the air can flow beneath it or
seal the APM air tight and only attach a tube to it which goes up to a point higher than the props are.

What would be your thought on this ?

Best regards,

Hi Jeepy,
The good news is it looks like we have found the problem.
The bad news is that even if you could compensate a bit for it in firmware by adjusting PIDs it would likely be an inadequate solution.
The baro really needs uncompromised air to work properly.
It takes relatively little prop wash back pressure to make a considerable difference in perceived altitude.
I have had turbulence / baro problems myself.
I strongly suggest moving the APM to that top frame plate, but in any case, some solution that gets the baro away from propwash / turbulence in the air and on the ground.
I probably need to emphasize this a bit more in the wiki.
Best Regards,

Hi Gary,

I’ll try if it helps moving the APM to the top frame plate.
I’m not sure because even than the APM is still a bit below the props. I’ll let you know if it worked or not.
Just in case it doesn’t works so well as hoped, which PID’s needed to be adjusted to compensate a bit for it ?

Thanks a lot for your help.


Hi Jeepy,
You really can’t fix this with PIDs, but you could try putting a cover over the APM (plastic freezer container or something) and then play around with how it is ventilated (holes) to reduce the effect of the prop wash / turbulence.
I have put warnings about this in several spots in the wiki.
Now that auto land is a reasonable option and RTL I think this is going to be a common problem and the only real solution is to have the flight controller in such a position and configuration that it is not much affected by the prop-wash.

Hi Gary,

As you suggested I mounted the APM as high as I could on my TBS Discovery.
It seems the bouncing at auto land is a bit better. It only bounces once instead of 3 times and it doesn’t goes so high during the bouncing, but it is still a problem.
Since I can’t move the APM higher, I’ve seen an external baro sensor in the 3DR shop: … sor-bmp085
I could place this ext. baro sensor to a higher and better location as the APM because it’s much smaller.
The problem is, it connects with the APM via the I2C bus and that is already occupied by the external compass.
Is there a way to connect both to the I2C bus connection ?
Also how do I set it up ?


I was just watching Randy’s video of his copter on autoland from his sonar test, it bounces (floats) a couple of times too.
Same problem I’ll bet.