Boat: throttle spikes to trim value after disarming

I keep failing to find the right setting combo to prevent this; after disarming from the remote the throttle defaults to trim value (1500us) which is 50% thrust for our setup. We need it to default to either 0 or minimum PWM. Which settings are we missing?

Thanks! Also, if you want to see our current boat build in process, it’s here: Autonomous Boat Testing at Matoaka - YouTube

06202023.param (14.6 KB)

hi, try to set the servo output corresponding to the output of the motor (SERVO

That is how we have it set. 1000us, 1500us, 2000us for 0-100% thrust. However after disarming it defaults to 1500us (TRIM) which then sets the motors to 50% thrust.

We found the solution:

Can you try setting TRIM to 1000.

1 Like

It doesn’t have the same effect, unfortunately, unless you also change your flight stick curves for throttle. We did this, then the mid-point on the flight stick which is 0, or trim (-100 → 0 → 100), becomes PWM 1000us. Then from mid to full it goes 1000-2000 with less resolution, while from 0 to mid it goes 985-1000…

Not sure if that makes sense.

The correct solution we found is to set MOT_SAFE_DISARM to 1 in the full parameters list

If you don’t have reverse anyways you could also adjust appropriate RC trim so whole stick range goes for forward movement.


Nice to see the video. Good looking boat.

I agree that setting the SERVOx_TRIM values could resolve the problem.

Inputs and output ranges are independent so it shouldn’t matter what the RC input range is I think.

I see that the MODE switch is setup to use Manual, Steering and Simple modes. Manual is fine but Steering and Simple are much less popular modes. Normally I use Manual, Acro, Loiter and Auto.

Interesting. We did modify the SERVOx_TRIM values such that it went 980-1000-2000 (min, trim, max) and the resulting behavior was that the center point on the flight stick (ch1) was 1000, then from center to top was 1000-2000 which then only had half the resolution.

@rmackay9 is it possible this could have been happening if scaling of the RCIN was not occuring?

(when in manual mode)

I think you want 980, 980, 2000.


I don’t really understand the comment about RCIN scalnig… but in any case, it’s normally a good idea to test that the motor outputs are working correctly using the Mission Planner’s Motor Test screen.

If possible maybe post an onboard log here captured when the issue happens. A parameter file is OK but it’s really all just guess work without a log file.

@rmackay9 Maybe I misunderstand; the remote (taranis qx7) outputs a pwm range per channel (1, 1.5, 2us for min/trim/max). This is then received by the flight controller and scaled to match the min/trim/max set in ardupilot?

When we set the (ardupilot) min/trim/max to something like 980/1000/2000 then what actually happened is that the throttle (rc1) went from 980-1000 for the stick position -100->0, then from 1000-2000 for the stick position 0->+100. Basically it cut the stick throw in half.