Boat spins in circles when using “go here” function or loiter

My boat works perfectly fine in manual mode. But as soon as I change it to loiter or try to use the “go here” function in QGC. It starts spinning around in circles.

You will have to read and follow the setup and tuning steps described here:

https://ardupilot.org/rover/index.html

That your boat works in manual mode does not mean anything regarding the other modes. Loiter, guided or auto mode can only work if the low level steering and speed tuning has been done properly.

I’m not sure what exactly I should be looking at. I did the accelerometer calibration and large vehicle magcal. Not sure what else I need to tune in order for the boat to not spin around in circles. This is very weird behavior and surely there must be some error somewhere that is causing this

It sounds like you have both the rc rudder input and servo output both reversed on the flight controller.

Where do I check if this is the case? I don’t use a rudder. Just left motor and right motor. I found a setting for changing how much it should throttle and lowered it to 50% however, this setting does not apply for when the boat is turning. It turns with 100% power. Where do I change this?

swap the left and right motors around and reverse the rudder channel on the transmitter.

Ok. So by swapping the motors. You mean left → right. And right → left?

Yes it sounds like you have them reversed but because you also have the rc reversed it works in manual mode.

1 Like

I will take a look under the hood and see. Thank you, kind sir.

Do you happen to know the parameter setting for changing how strong it will turn? I want to turn it down to 50%

Instead of changing thinks on random, make sure the motors run forward with a pwm signal higher than 1500us and backwards with a signal lower than 1500us. And the left throttle output controls the left motor, right throttle output to the right motor.
Did you finish the tuning steps for throttle/speed and steering like described in the wiki here:

https://ardupilot.org/rover/docs/rover-tuning-process.html

I went through the link.

Boat spins in aero mode too. So I can’t use acro mode to tune it.

For checking what happens during each signal, do I need a servo controller?

When turning, output goes to both motors. One motor does clockwise rotation and one counter clockwise

is forward and backwards correct?

In manual mode. Yes. I had to reverse the RC channel output though

I think you need to start again and undo all the reversing you have done so everything is working normally, with so many things reversed It’s hard to know where to start. its possible its your motors that are actually turning the wrong way and you have reversed everything else so that its working in manual.

you shouldn’t have to reverse any of the RC outputs to get it to work in manual mode.

make sure the motor actually goes forwards when given forward control input. If it’s going backwards, swap the motor wires around to get it to go the other way.

I’m not going to say anything that hasn’t already been said, but I will try to say it in a different way so that maybe the sum of all the info here will make sense.

Start with the radio. On the mandatory hardware/radio calibration screen of Mission Planner, confirm that PWM output increases as throttle command increases. If you’re using a steering mix, a left turn should result in a lower PWM value than a right turn on the steering channel. If you’re using “two paddles” steering, you can ignore my comment about the steering channel and simply confirm that both throttle channels move the same way.

Next, confirm that the motors are connected to the proper left/right outputs. You need to do this by physically following the wires, since they both turn with throttle input.

Finally, confirm that they turn in the correct directions. Once the radio is set up correctly, you can do this in manual mode. Push the throttle(s) forward. They should command forward thrust. Now try a left turn. The left motor should slow down/reverse, and the right motor should speed up. Reverse the throttle servo directions (or ESC wiring) as necessary.

Now test in Acro mode. This is arguably the most critical crosscheck of your work. It confirms that the autopilot is correctly interpreting RC commands and translating them to motor output.

Then follow the first drive/tuning instructions that you have been directed to use multiple times.

1 Like

I will do the first steps. But I can’t use acro mode. As I said. The boat starts spinning as soon as I change into acro mode.

You didn’t read what I wrote.

I read what you said. And I have already done what you say. As for acro mode. I Can’t use it because the boat spins in circles.

I ask again, if anyone knows how to change throttle max for turning, please let me know so I can problem solve without risking to either burn the motors/esc or sink the ship. As soon as. I enter any other mode than manual, boat starts spinning around with 100% throttle. Even though I set Throttle max to 50%

If I test in water, I risk flipping the boat over. If I test on land. I risk burning the ESC or motors.

No. You have reversed RC channels to force manual mode to work. Undo that! Troubleshoot as I described.

Then you should be able to get Acro mode to work.

I was attempting to tell you what @geofrancis has already said, but expand to give you explicit instructions. If you don’t go back to RC transmitter setup and proceed from there, nothing else will work.

I don’t know how else to say it.

Ok. I get it. English is not my first language. I will undo the reversing and see what happens. Are you sure that the RC thing is not because that’s just the way Herelink is programmed to work?