"Board has been retired" (APM 2.6)

Hi Guys

I finally got the device drivers installed after I downloaded a arduino program (or shall I say my wife figured it out as she is an automation whizz)
Now when I connect the board mission planner says " This board has been retired. Mission planner will upload the last available version to your board (AC 3.2.1/AP 3.4.0)"
I press ok and all gets uploaded, once done and I connect to do the mandatory hardware I do the compass setup it shows compass 1,error: 99
If I move it around as instructed I don’t get any reference samples.

Has anyone had a similar issue before.

You may have got a clone 2.8
So just for trial and error, connect the I2C connector to the socket under the GPS socket.
If that is where you have it then you do have a 2.6 and it needs to be stretched over to the I2C port

You will get the “board is retired” message to let you know APM 2.5, 2.6, 2.8 maxes out with firmware 3.2.1

You can also get a compass error if the wires in the i2c connector are swapped. BTDT…

Hi guys, sorry but Ive got no idea what you are talking about. I did not know that I would need anything else than a USB cable to set up the apm

How about some details of your setup?
A pic often works wonders.

You haven’t given any real details about the Flight Controller.
Where did you get it?
What version is it?
Mission planner is seeing it as an older APM board (8bit processor) and is simply selecting the correct version of firmware to load, which is 3.2.1. Only the latest 32 bit boards with more memory will run the latest firmware but the old APM are still a solid flying auto pilot, just without all the latest bells and whistles.

Now your issue is what you have plugged into the APM, namely the compass.
This will most likely be integrated in the GPS unit. (hint: a pic will help, saves me having to guess)
So this compass unit has 2 cables.
1 goes into the GPS port and 1 goes into the I2C port (the compass is an I2C device)

Now if I could see what you have and what you are doing it would be easier to help further.

I’ve changed the category to “General” because when set as “Blog” it appears on the front page of ardupilot.org.

Ah now I see. Yes I now remember reading that the compass is integrated with the GPS.
So… I need to plug all that in before I can do the initial setup.

Thanks for that, newby with allot of questions. this forum is great.

Thanks guys

Good morning Guys
I have done what was suggested and it worked perfectly, when it came to radio setup I didn’t get any response from the Rx only to reallise that the Rx was in sbus mode, flipped it back and it worked.

Tonight I’m connecting the ESC’s