BN-880 with Kakute H7 compass doesn´t work

Hello, I have got Kakute H7 (Arduplane 4.2.2) with BN-880 GPS and compass. GPS is working fine and outdoor I get 3D fix immediately. But I always have Bad Compass Health displayed and compass Onboard Mag Calibration doesn´t do anything. I checked that SDA and SCL pins have good connections. When I disconnect it, MP tells me that compass was disconnected. When I tried QGC, it says ‘mav_cmd(42424) command failed’. Does anyonoe know where the problem could be?

Param list:

params.param (19.4 KB)

My guess would be bad compass. It’s almost certainly not an HMC5883

According to this description, it should be.

It will be some kind of clone - Honeywell don’t make them anymore

It is strange. I bought it from here.

Well, I tried to flash INav to FC and Compass worked fine. Is it possible that I have something wrongly set in MP? I would very much like to stay with Ardupilot.

My guess is that this is a QMC5883L with the ID changed to HMC5883L, these are known to exist but I don’t think we support them properly. I’m afraid I can’t see anything that you are doing obviously wrong.

I checked many sites and they all sell it as HMC5883L. I found that even people in the discussions use it with Ardupilot just fine. I have a QMC5883L on one of my planes and it also works without a problem and when I connected it to this FC the compass worked. Maybe I will try to flash older version of Ardupilot and try if it works.

Unfortunately I don’t have an 880 to test so can’t help any further I am afraid.

When I flash 4.2.2. and load parameters, Mag Calibration worked but when I reboot it, it doesn’t work again. In theory, do I need a compass to fly a wing? I also fly autonomously.

In theory not, but MAG is the best yaw source and I have found things to be not great without it. Depends how good your GPS is - BN-880 is pretty cheap so not great I would say.

Seems strange to me that it’s finicky like this - try resetting everything, so load copter - say - and then re-load plane and then just do the mag cal and see if its stable.

I tried but unfortunately nothing happened this time. I also tried changing the voltage to 3v3 but that didn’t help either.

Thanks for the advice, the problem was with auto orientation. Just set it manually and it works.