BN-220T GPS not recognized by Matek H743-Wing with Arducopter 4.3.6

I’m quite new hear and it’s only my second day working with the Matek H743-Wing, but here is my situation:
I’ve connected the BN-220T GPS module to the Matek H743-Wing’s RX2/TX2 pins, along with GND and 4.5V. The BN-220T’s blue LED labeled “TX” is blinking and so is the red LED labeled “PPS”, which indicates that it’s powered on and transmitting data. However, I’m still getting a “No GPS” notification on the HUD in Mission Planner.

I have verified that the wiring for the GPS module is correct and double-checked that the TX and RX wires are connected to the appropriate pins on the flight controller. Additionally, I’ve tried connecting the GPS module to different UARTs on the flight controller (e.g., UART7) while powered to a battery (UART7s 5V pin only is powered when battery is connected) but with no success.

In Mission Planner, I’ve set the GPS_TYPE parameter to “1” (Auto) and the GPS_AUTO_CONFIG parameter to “1” (Enabled). I’ve also set the SERIAL2_PROTOCOL to 5 for GPS and the baud rate to various values including the standard 9600. Under the “Status” tab, the “gpsstatus” and “gpsstatus2” parameters both show a value of “0,” which indicates that the GPS module is not being recognized by the flight controller (or at least that’s what I think it means).

What am I missing? Any assistance would be greatly appreciated.

The 1st suggestion is usually do you have Tx>Rx and Rx>Tx. And even if you think so swap them anyway.

1 Like

Thanks Dave,
I’ve tried that, but sadly without success. Do you have other things I can try? It seems to me like setting up the gps should be fairly straight forward, I’m probably missing something quite simple.

You can post your parameter file, perhaps something was missed. I have a few of those Matek boards and as you say it’s typically straight forward.

1 Like

Check Matek’s “Ardupilot Wiring” info for the H743 wing, TX2/RX2 is shown as being “Serial 3” in Plane

1 Like

Thank you, that was it! Can’t believe I didn’t catch on to that… Have a great day!