Blue Robotics Ping Sensor not working on Anything above ArduRover 4.0.0

I have a BR Ping rangefinder, and am only able to get it to work using Ardurover 4.0.0. This would be acceptable, accept that I cannot get the compass on my Here3 unit to work on this version of ardupilot. Any help is greatly appreciated.

Sorry for the delay in responding, I’ve reproduced this problem and hopefully we can find a fix (see issue here)

Really sorry about this but thanks for the report

@TCastillo1,

I think the issue may be that the the firmware on the BL Ping sensors shipped from BlueRobotics has changed and the driver isn’t backwards compatible. I’ve reached out to a couple of BL developers and hopefully we can figure out a way to upgrade the firmware. I tried to follow the instructions on this BL wiki page but wasn’t successful.

OK, I managed to update the ping sensor’s firmware to version 3.28 and it is working with Rover-4.1 (and higher).
image

I had to update using an FTDI serial cable (aka USB to Serial converter) to connect the PingViewer application to the sensor. I could not get AP’s serial passthrough to work sadly because that would have saved messing around with wires.

That’s great. I tried this a few weeks ago with no luck, but let me give it a go again and see what happens. Thanks!

Updated it and it works perfect!
Thanks!