Blheli32 ESC on Radiolink Pixhawk 2.4.8 (fmuV2) not working using any protocol

The ESC I’m using is T-Motor V50A 6S 4IN1 32BIT
I have tried setting up the ESC using all the protocols it is supposed to support like DShot and Normal (PWM). Tried configuring the servo outputs to Aux channels (1-4 and 2-5). Hooked up the ESC signal wires to the Aux channels and Main channels as well. Changed the BLH parameters as well.

Best I could do was getting BlHeliSuite to connect to the ESC via passthrough and only Motor 1 spins while trying Motor Test on MP
Motor Test seems to be able to spin the Motor 1 (occasionally, I should say). Radio inputs and BlHeli motor test don’t work either. It’s not a firmware issue either as everything is as updated as can be and the firmware is provided by the manufacturer. Haven’t tried connecting ESC telemetry.
What can I do?
Here is the parameter file

I feel like I’m out of options
1.param (15.5 KB)

Try MOT_PWM_TYPE 5 or 6 and see if the ESCs respond in the MissionPlanner motor test.
The other settings all look OK so far.

If this anything but a very small quad, then in BLHELI32 settings make sure
Low RPM Power Protect = OFF

1 Like

I can’t properly change the setting in BLHeliSuite32 as the ESC isn’t properly read.
I have already tried changing protocols but didn’t solve anything.

I should be having 4 ESC’s in BlHeliSuite, right?

Motors don’t spin either. I got only 1 motor to spin after trying something I don’t remember.

Apart from MOT_PWM_TYPE 5 or 6 , I cant see anything else wrong (I might be missing something)
Could be wiring, have you got a photo of the wiring from pixhawk outputs to ESC ?

You could put BRD_SAFETY_MASK,12543 back to 0
BRD_SAFETYENABLE,0 to disable the use of the safety switch.

Do not hook up the B+ or CURR to anything (the ones in the small connector)
Only connect GND 1 2 3 4 to your AUX outputs 9 10 11 12. You can connect up the TELE wire to a serial port later if you wish.

1 Like

I have wired up the ESC signal wires just the way you have suggested. However, I’m still sending a picture of the wiring after a while.

I can’t send the picture. I have wired Motor 1-4 signal wires to Aux Output 1-4 accordingly and the ground wire to the ground serial. The ground is not really above the motor signal wires but that doesn’t matter as ground is a shared bus connection on the FC.

Is there anything else you can think of?

Throw anything from Radiolionk in the trash and get a new Flight Controller.

Or, try using the Pixhawk1 firmware not fmuV2. fmuV2 is incorrect for all of those Pixhawk 2.4.8’s but who know’s with Radiolink.
This is their only claim to fame:
The manufacturer is also apparently not abiding by the GPLv3 license

Oh heck, Pixhawk already costs so much and I’m out of money for this project.
I don’t get it, everything else seems to work just fine.
GPS Lock is established. Signals from the transmitter are also getting received. Why would the ESCs not work? Funny thing is, I just tried calibrating the ESC using ‘Normal’ protocol and I got the correct beeps but the motors still didn’t respond.

Some combinations of FC and ESC can be problematic. Nothing to lose really by Flashing the Pixhawk1 firmware but your choice of course. Download the .apj file from here and use Mission Planners “load custom firmware” to flash it.
Then set the protocol to Dshot600. Then try each of the choices in the SERVO_DSHOT_RATE parameter and see if Motor Test will spin all motors. Set the throttle % at 10 or more.

I’ll obviously try this firmware since someone as wise as you has suggested it.

Guys, I’ve tried many things. However, I couldn’t get the motors to spin. But I’ve noticed a few things that I’m writing down here-

  1. During calibration under any “analog protocol” such as OneShot, the calibration goes smoothly but after arming the ESC just beeps once every second.
  2. When using DShot, the ESC plays the startup sound when armed and starts beeping once every second after a few seconds (sigh… again).

Any suggestions on what I should do?

Didn’t we do this already?


It’s still not working.

I’ve solved the issue, people. It was such a negligible setup issue of the ESC :melting_face: . The accepted PWM frequency range was set at 96k which is not what the FC supplies. 2 weeks of staying up at night because of such an eccentric issue…

Good that it’s working but it doesn’t work that way. The PWM frequency range in the BLHeli_32 settings is the rate to the motors not from the Flight Controller.

1 Like

Whatever, didn’t read the manuals. I’m just happy that it’s working. Happy new year!