BLHeli32 ESC 4 in 1 not working with ArduPlane 4.1.6 and MatekH743

Hi! I’m building a quadplane tailsitter without controlling surfaces and having an issue with the ESCs. They doesn’t “talk” properly with ArduPlane 4.1.6 but works well with ArduPlane latest from 3rd January and with ArduCopter 4.1.3 without any hardware changes and mostly default parameters, so I think maybe is a parameters configuration problem or some software bug that’s is already solved in latest but not in stable nor beta branches. I hope maybe someone here would help me finding what’s wrong and if possible, solve it.

The FC I’m using is the Matek H743 Mini (hwdef MATEKH743) wiring the first 4 servo outputs to a 4 in 1 ESC with firmware JHE Aria 32 - BLHeli_32 rev 32.8 like the picture available in the wiring tab in the product description.

The parameters for ArduPlane (4.1.6 and latest) are the default for this target adding the next ones:

  • Q_ENABLE = 1
  • Q_FRAME_TYPE = 1
  • Q_FRAME_CLASS = 10 in 4.1.6 and 1 in latest
  • Q_TAILSIT_ENABLE = 2 only in latest (in 4.1.6 this parameter doesn’t exists)
  • Q_OPTIONS = 128 only in 4.1.6 (in latest seems it isn’t needed because Q_TAILSIT_ENABLE forces Qassist, but, after setting Q_TAILSIT_ENABLE it acquires the 262144 value, the bit for the “ARMVtol” option, that only exists in latest)
  • SERVO(1-4)_FUNCTION = 33-36
  • SERVO(5-8)_FUNCTION = 0 (It defaults to 33-36 because the written values of the previous parameters)
  • Q_M_PWM_TYPE = 6

For ArduCopter 4.1.3 the default too, adding the next ones:

  • FRAME_TYPE = 1
  • MOT_PWM_TYPE = 6

Also, the BLHeli passthrough works with ArduCopter 4.1.3 but it doesn’t works in ArduPlane, neither 4.1.6 nor latest.

Thanks in advance for everybody who can spend his time trying to help me!

@andyp1per perhaps you can help him

1 Like

Very strange. I have that board - please can you send me a full set of parameters for the non-working arduplane and I will try?

Hi again! Thanks @hwurzburg and @andyp1per for your time, I’ve solved it with a stroke of luck while preparing the files for send to you. I wondered, what could happen if I leave the Q_FRAME_CLASS parameter to 1 like in latest? And it worked :partying_face:

So, the confusion was I understood that for enabling tailsitter in 4.1.6 was necesary to set Q_FRAME_CLASS to 10 (TailSitter) and Q_TAILSIT_MOTMX and they are exclusive, one or the other. Maybe for avoiding this kind of mistakes in latest now Q_TAILSIT_ENABLE is an independent parameter.

Thanks a lot and sorry for disturbing!

1 Like