Servers by jDrones

Blheli_32 passthrough issues


(Evgeni Chipev) #1

Hi all
I seem to be having a problem connecting to blheli suit through Pixhawk cube runing arduplane 3.93, what I am missing? Everything is working if I flash it with arducopter… please see attached screenshot.

Thanks in advance for your response.
Evgeni


(Boom_Boom) #2

Are u using an “aux out” or a " main out"?
http://ardupilot.org/copter/docs/common-dshot.html


(Evgeni Chipev) #3

Yes it is connected to aux1 (servo9 is set to 70). Esc is working as it should just can’t get it to work with blheli suite it says it’s connected but can’t read the settings.
Maybe it’s something related to arduplane code it self as everything works(same settings) perfect with arducopter.
Has anyone got it working? Could you please share your parameters?

Thanks again!
Evgeni


(Boom_Boom) #4

I’ve used it a few times without issues.
But on a Pixracer and copter firmware.


(Nathan E) #5

Your BLH_mask is not correct. It should be a much higher number. I think the newer version of mission planner can help with setting the correct number for masks.


(Evgeni Chipev) #6

Hey Nathan

What do you suggest to try as a number there? I’m using servo9 output(aux1)?

Thanks in advance!


(Rolf) #7

Try 256
regards Rolf