Big yaw jump disarmed on ground

Hi, I have a big issue with my yaw values. I am using a Mamba F405 Mk3.5 Mini with Arducopter 4.2.0-dev.
I tried to fly an auto mission with two parts: First part is a mission with a takeoff, some waypoints and a landing with a disarm command. The second part of mission starts after checking if everythings all right and manually rearming. Here comes the problem. After the takeoff, the drone did a yaw turn and took off into the distance till i disarmed it. In the picture of the log you can see the compass log in comparison to the yaw value. EK3_SRC1_YAW is set to compass, so the compass should be the source for yaw, but the compass values don’t change but yaw does.
I marked the two values. Yaw changed in 0.001 seconds from 185.4 to 332.92.

Not only did the yaw values jump, the roll value had also some issues.
Summing up: the pos estimate using the ekf and the actual locationn by gps differed and caused a gps error (as it should) but the problem wasn’t solved.

The link for the .bin

do not use 4.2.0-dev, please update to 4.2.0-rc2 or newer.

1 Like

Hi, thanks for the advice. I updated the version and I recalibrated the compass and now it works. Actually we tried hard to find the problem in the logs until a teammate asked if the drone shows the correct north. After some closer inspections we discovered a huge compass error of about 45° and first thought the auto alignment was wrong (compass is rotated exactly 45° from origin of FC) but it turnt out to be just a wrong calibration.