Benewake TF03 not working


Running ArduRover 4.0.0 with a boat frame, trying to get TF03 working. Follow the guide. I added “-E /dev/ttyUSB0” to the ardurover-config file on my Emlid Navio2 config, which should, as far I can grasp, map to Serial4. Sat Serial4_protocol to Rangefinder(9), serial4_baud to 115200(115), and serial4_options stays at 0. Rngfnd1_type is set to 27, but I’ve also tried 20. Docs are only referring to difference in Copter, so I’m starting to worry TF03 is not compatible with ArduRover…

Any way to see if ardurover gets the information it needs? I did a screen of /dev/ttyUSB0 and it seems to be working fine. If i run “sudo fuser /dev/ttyUSB0” I also see the pid of ardurover having it, so I’m quite certain it gets redirected.

Current running process looks like: “/usr/bin/ardurover -A udp: -C /dev/ttyAMA0 -E /dev/ttyUSB0”.

I’ve of course rebooted between changing the settings. Both Rangefinder1 and sonarrange show up at 0 no matter what :frowning:

While at it, how does ardurover choose which rangefinder is which number? I’m actually hoping to get 4 LiDARS up and running to be able to do wall-hugging on both sides of the boat. If anyone is keen on a making a few beers by being a support to get it up and running, please do contact me. The rover is doing decent at this point, but needs a bit more tuning, and I’d love to have someone to sparr with.

Hope someone will help me along, we’re trying to do some automated sea port cleaning here :slight_smile: