Servers by jDrones

BeagleBone Blue released, Linux-enabled autopilot for 80$

linux
hardware
arduplane
arducopter
ardupilot

(Mirko Denecke) #61

@burzum The 5 Volt on the servo rail is disabled by default.


(Piotr Wachowiak) #62

Ok, that’s an issue probably. It’s good idea btw, I wouldn’t power arm servos from rail, just wanted to test configuration.

Next week I will replace copter pixhawks with BBBL, I wonder how it can fly…
From my perspective, the biggest problem is mapping BBBL connectors terminology to ArduPilot terminology - I will try to document it.

best regards,

Piotr


(Valentin Schellhorn) #63

@mirkix

could you please help me out and make a statemante if it is posible to change the port (connector E4 pin4) for the PPM input signal to another port and how…?

Thanks a lot!

Best regards Valle


(Mirko Denecke) #64

@Valle Hi Valentin,

the pin can not be changed because there is hardware used which is only available at this pin.

Regards
Mirko


(Valentin Schellhorn) #65

damnit! Well I suspected that, thanks a lot for the fast answer…


(Kyle B) #66

I’ve been trying to get a gps unit working with the Beaglebone Blue and Ardupilot, but it won’t connect. I was concerned that maybe something was wrong with the gps, but I connected it to an ftdi cable and it worked with U-Center. It’s a ublox M8N: https://www.amazon.com/gp/product/B01KK9A8QG

I tried a bunch of commands including
sudo /usr/bin/ardupilot/blue-arducopter -C udp:192.168.7.1:14550 -B /dev/ttyO5
-B… ttyO2
-D… tttO2
and with just the -C parameter.

Not sure how I’m supposed to set it up, but since its connected to uart2, I tried the parameters above. But I guess since it’s connected through the gps port, it shouldn’t need any parameters?

Anyways, it isn’t working. Maybe it needs a different configuration loaded onto the M8N? I tried to find the configuration file, but all the links on the Ardupilot site for the M8N config file were broken.

The specific symptoms of the issue is that the gps is getting power, but in APM Planner there is no gps fix, no gps satellites, etc. So it clearly just isn’t communicating with the gps.


(Kyle B) #67

Also, separate issue. Your installation page says that the command to run ardupilot is:
sudo /home/debian/arduVERSION

But there is nothing installed there. Looking in the comments, it seems to install it to /usr/bin/ardupilot/blue-arduVERSION

So unless my installation was weird, it would be good to fix the installation page to show the correct path.


(ppoirier) #68

Kyle,
The best is to diagnose the problem using a light terminal like MINICOM.
Open a session on your BBBlue, connect to internet and type sudo apt-get install minicom
Before launching you should check what ports are installed typing ls /dev/tty*
Remember that the ttyO4 or ttyO5 are using the letter “O” … that is quite confusing.!!

Open minicom , set the ports , the speed and confirm that you have data from the GPS

Yoy should launch arducopter using “B” assigned to the designated ttyO
And you must set the serial 3 with mission planner to 38 kbaud and device 5 (GPS)

Here is the a table showing the correspondance between Ports Letter and Ardupilot parameters for internal serial ports

REFERENCE for virtual serial assignation when launching ArduCopter:
A console Serial 0
B 1st GPS Serial 3
C telem1 Serial 1
D. telem2 Serial 2
E. 2nd GPS Serial 4


(Kyle B) #69

Thanks that clears some things up. I will try that tonight. If I do need to change the settings on the gps, what is ardupilot expecting? Obviously 38400 baud, but what format messages? There’s lots of settings in U-center.

I guess the tty port number that it ends up on will be random? Or is it tied to the uart number on the BBBlue schematic? I did try -B /dev/ttyO2 and that didn’t work, so maybe the port number isn’t tied to the uart number.


(Marc Dornan) #70

Hi Mirko,

Any progress on getting Voltage and Current monitoring working with this board. I was thinking about putting it in a plane and testing the one I have on something other than the bench!


(Mirko Denecke) #71

@Marc_Dornan Hi Marc,

unfortunately no progress until now.

Regards
Mirko


(Marc Dornan) #72

No worries. I would dive in and lend a hand but would probably take a while to get going. I will see if I can find the time.

In the meantime I can can rely on Frsky telemetry.


(Mirko Denecke) #73

@Marc_Dornan Seems to be a bit more complicated, because the analog IIO is not available at the BeagleBone Blue.


(Marc Dornan) #74

I see. Can we just bypass the issue and feed Frsky SPort sensors into the Beaglebone? They have decent current and voltage sensors.

Always wondered why this was not just an option: to use Frsky sensors in Ardupilot. We can get the SPort out of Ardupilot. Why not take real sensor data in through FrSky SPort as well?

It is a potential minor barrier more people using the board if we cannot get voltage measurement at least into the FC.


(Jason Kridner) #75

Should be easy enough to fix the .dts.

BTW, I removed the need to have your custom .dts.

I got a 450mm built up from a ErleCopter I had. I’m now working on a 220mm:
https://gist.github.com/jadonk/6080ca92d6e225eb89d33ad7744e1775


(ppoirier) #76

Thanks for the update Jason,
good to know that the man behind the Blue has joined the ArduPilot discuss group


(Marc Dornan) #77

Jason - does fixing the .dts enable the analog in ports to be used in Arducopter? Sorry if this is a spectacularly uniformed question from someone with very limited Linux skills!


(Mirko Denecke) #78

That would be nice! But I think it is not that easy, the Robotics Cape does some mmap with the adc.

Regards
Mirko


(Davidfsh) #79

Maybe it is a silly question, but I really cannot figure it out. The Beaglebone provide 6V PWM signal. However, the pwm signal provided to esc is usually 5V(I see many people mentioning 5V as a upper limit). What will happen if I just connect the esc to the Blue’s pwm output? I think of using extra circuit to do voltage level shift, but my boss does not like this idea and want me to find other compatible esc. How do your guys deal with esc with Blue? Is there some recommended esc compatible with Blue without extra circuits?


(ppoirier) #80

Take a look at this: https://servodatabase.com/servos/all
You will see that 99% of standard servos are rated 4.8-6.0 Volts and ESC ar somehow based on the same specs.