Servers by jDrones

BeagleBone Blue released, Linux-enabled autopilot for 80$

@ghostrider I will give it a try tonight , and report back

1 Like

@Thalaivar yes thats it, you can check the FC build options with ./waf list_boards
More here: https://github.com/ArduPilot/ardupilot/blob/master/BUILD.md

1 Like

@ppoirier
Thanks a lot, you’re a real saviour :slight_smile:

@ghostrider Just tested and it works fine
I see signal change on my oscilloscope according to servo setting (low-high-toggle)
Here are servo 7 setting (they where defaulted to these values on my release)

SERVO7_FUNCTION 0
SERVO7_MAX 1900
SERVO7_MIN 1100
SERVO7_REVERSED 0
SERVO7_TRIM 1500

Mine doesn’t work with the prebuilt version, but if I compile it myself and run command echo 1 > /sys/class/gpio/gpio80/value before starting ardupilot it works.

Do you run any scripts that enable the Servo rail before starting ardupilot?

Ahhh OK you applied my trick :slight_smile:
https://discuss.ardupilot.org/t/beaglebone-blue-based-flying-wing-do-i-have-whats-needed/20717/12

Yes power is not applied by default … sorry I overlooked that

And yes , you can copy that in /etc/rc.local
/bin/echo 1 > /sys/class/gpio/gpio80/value

1 Like

I did!! Is there a way to get this working by default so that new users won’t have the same problem as me? Either having it prebuilt into bbblue or doing it in mission planner or ardupilot?

@ghostrider Good point

@mirkix could you please add the rail power info and script on the wiki please ?

I’ve been trying to connect to a GCS with the 3DR radio V2. I connected the autopilot side radio to the USB port of the BBBlue and used the appropriate port (/dev/ttyUSB1) while running ardupilot. However I am not getting a vehicle connection (using APM Planner 2.0). I can do the 3DR firmware stop perfectly fine and it updates the params on the remote perfectly. But I am not getting a connection to vehicle. How can this be solved?

Hello @Thalaivar , I see you are making progress :slight_smile:

So according to Mirko’s instructions : https://github.com/mirkix/ardupilotblue#run-ardupilot
If you want to connect the radio to the usb1 (and that you have a good connection working…), you have to set telemetry within ArduPilot parameter == serial correctly configured @57600 bauds using SERIAL1_BAUD and setting for Mavlink SERIAL1_PROTOCOL.

Then you then can connect by issuing:
sudo /home/debian/arducopter-quad -C /dev/ttyUSB1

1 Like

@ppoirier What do you mean by,“set within Ardupilot”??

You connect locally = using USB (192.168.7.2) and launch
/home/debian/arducopter-quad -C udp:192.186.7.1:14550

Then on mission planner you can connect usind UDP @ 14550
Then you can set parameters === read the ardupilot wiki

Ah right, I was attempting to do this with the 3DR radios, that would work right? As in, I run:

sudo /usr/bin/ardupilot/blue-arducopter -C /dev/ttyUSB1

on the BBBLue, and I connect to it using APM Mission Planner 2.0

If serial1 is not set correctly , you cannot use the radios ==This is why you have to go UDP first to gain access to parameter

1 Like

Thanks a million for clearing that up!

Why is it that mirko’s instructions on running AP, do not work, it just says “command doesn’t exist” when I try to run:

sudo /home/debian/arducopter (plus param)

whereas this works: https://dronerai.de/blog/page/2/

Its all depends what you have loaded and where its loaded
Sorry but these questions are not related to ardupilot, I think you need to practice Linux a little more :wink:
BTW that looks like a really good blog

2 Likes

Hi all. I’m trying to get ardurover working on the BB Blue. I have the GPS and telemetry radios hooked up and working well, and I can connect with mission planner via the radio or wifi successfully.

Like others, however, I’m having trouble getting the RC receiver to connect. I’m using a Futaba R3006SB, and I’ve tried it in both s.bus and sbus2 mode. I am powering the receiver off 5V from the BBB power connector and have connected the s.bus pin the E4 pin 4. I set and verified the P8_15:

debian@beaglebone:~$ cat /sys/devices/platform/ocp/ocp:P8_15_pinmux/state
pruecapin_pu

On the oscilliscope I see a nice 3.3V digital signal coming over the s.bus pin, but ardupilot just seems to ignore it. Any ideas?

Thanks!

@bmazin Hi Ben, are you sure that you are using pin 4? When I zoom into your pic it seems connected to pin 3? But the pic has not such high resolution, so maybe I am wrong. It is tested successful with a FrSky RX.

Regards
Mirko

Yeah, its in pin 4. Anyone successfully used a futaba s.bus receiver with the beaglebone blue?

Servers by jDrones