Beaglebone and FS-IA6B Problem


i;m New in this forum,so i don’t know where is right place to post about my Problem.
I have beaglebone blue with Flysky Receiver and i’m unable to find right way to Work.
Followed all the instruction here for installation ,with last image,and all seem to be ok.

mission planner connect ok,gyroscope,etc work.
connected sbus on Receiver to E4-4,and tried dsm2 too without result

in mission planner ,in mandatory,radio won’t Work.
i have re-installed .IMG ,no Change

Does anyone can help ?
Thanks in Advance!


I guess you are stucked at the infamous PRU startup issue… Look at my comment on @Yuri_Rage Beagle Blue Setup Guide

Hi ppoirier,

thanks for your information,

tryied without succes,surely i missing something. i have pixhawk rc,connected my fs-ia6b and it work,i can eliminate this can cause problem.

i will re install (again) with fresh .img and redoing all installation precedure.

if it work,(this year…) ,i will give information about my resolved problem.
Many Thanks Again!

I do this
lsmod | grep uio

uio_pruss 16384 0
uio_pdrv_genirq 16384 0
uio 20480 2 uio_pruss,uio_pdrv_genirq

can be ok?

Looks good, dont forget to enable PRU
/bin/echo pruecapin_pu >/sys/devices/platform/ocp/ocp:P8_15_pinmux/state

Hmmm,it Work!

Without your help, I would never have been able to make this receiver work! (or another)

many thanks again!!!

1 Like

@ppoirier @2001cprx What was the wiring for the IA6B to the BBB if you don’t mind me asking! I’m not sure what it is myself and I haven’t been able to figure it out. I have an FS-ia6 but the wiring is incredibly similar for both!

It needs to be connected to pin 4 on the E4 connector.

This photo from Mirkix’s GitHub guide shows the pin quite well, it’s the one with the purple wire. Just make sure the transmitter is set to SBUS instead of IBUS, as the beagle bone doesn’t recognize the IBUS protocol.