Baud rate issue with Telemetry (not solved)


I am using 3DR telemetry to connect my computers with Mission Planner with my helicopter. On my PC I have no problem making the connection. I changed the Baudrate in the Device Manager options and everything works fine. When I try to do the same on my laptop with Mission Planner, it does not work. The message “ConnectFail” appears

And I see the error that I attached in the photo.

Also, if I try to make the connection in my laptot with other soft ones like APMPlanner or UgCS, the telemetry connection works fine! So, do I think the problem is only in the Mission Planner software? Does anyone have the same problem and have a solution? I have tried previous versions of Mission Planner but none connects.

Thank you

First you are sure that the port is “seen” by Mission Planner? You can remove the telemetry from the laptop and the port disappears from the Mission Planner list of available ports?

Make sure the drivers for the USB were installed ok. Remove Mission Planner and reinstall making sure there is nothing on the laptop like anti-virus/defender etc blocking the installation of the usb drivers.

Thanks for answering.

Yes. Mission Planer “sees” the port where the temeletry module connects. The correct port appears and corresponds to the one seen in the device manager.

I guess the drivers are well installed since the module works with applications such as APM Planner or UgCS. Still, I’ll try to install it with the antivirus turned off (although I do not think that’s it).

Any more idea of what the problem may be?

Thank you very much

I am not at a windows box so i can’t look but there is a whole page of settings for the 3DR telemetry Sik Radios maybe something wrong on page?

In windows system or in Mission Planner? If is in Windows i don’t know where is this page. If you make reference to the MissionPlanner page, yes, I check the configuration and all options are equal that in the PC where the telemetry works properly. I’m thinking about it, and I think that have to be something about the Mission Planner soft because the telemetry works well in other softwares (APM Manager, UgCS)

The page I mentioned in on the option hardware section. There is no problem with telemetry, as far as I know with Mission Planner. You might try a different version of Mission Planner to see if a bug was introduced but I have not heard any problems.

I tested with other versions of Mission Planner but always fail. Next week I’m going to restore the windows installation in my laptop. And then, I’m going to install again the drivers and Mission Planner. If telemetry fail again I will make a video with the issue. Thanks Mike

How did you make the telemetry connection between Mission planner and UgCS?