Battery voltage jumping all over the place

Hi. I am new to UAV’s, “Pixhawk” clone is my first autopilot. I have some expirience with racing quads, cleanfligh, NAZE32, Seriously Pro F3 etc.

My problem is calibrating battery voltage in mMission Planner. I enter measured valu correctly, but voltage calculated jumps ± 3V from what actual voltage is. And it is doing it every half a second or so. No load on battery. Once it states 14V, a second later it is 17V.

Also, ( I am not sure if this is relevant) I have noticed that Vlotage divider (calced) is not persistent. Entering same value for voltage measured consecutively will provide greatly different values…

I humbly ask for help here


A screenshot of the “Battery Monitor” page in MP might help. However, as far as I know if your using a 3DR Power Module (or clone) then only thing you need to enter is the Battery Capacity and tick whether you want
MP to Alert on low battery. MP calculates everything else.
Thanks, Grant.

I did what you say except it never worked for me.
There is a screenshot if it helps:

You have “Sensor” configured as Other. Am I right in thinking you have some custom hardware to monitor the battery voltage and current and that you don’t have a 3DR Power Module? If you have a pixhawk clone it should have some sort of Power Module with it.

Thanks, Grant.

I have that issue too! Drives me nuts. I have a genuine 3dr PM and have tried every setting I can think of and it’s just never right. It also constantly warns me of a low battery even though the battery level is higher than the warning amount.