Battery Voltage display stopped updating on MP

Out doing some flights with AC 4.2.2 and I noticed that the battery voltage on the GCS stopped updating. Not sure if there’s a connection but I noticed it stopped the moment I switched from loiter to auto. In the .bin the voltage is being updated as expected, and on the Yaapu telemetry on my radio the battery voltage was also being updated as normal. The problem was only on the laptop.

All the rest of the HUD information seemed to continue as normal during the flight.

I’ve included the t.log and the .bin from the flight. Mission Planner was running on windows. MP-Beta updated in the last few days. Telemetry was via SIK radio.

Tried again today:

  • MP build 1.3.8261.19181 on Windows. (updated beta this morning, a few hours ago). The problem is still the same. The battery voltage does not update when in Auto or RTL. If I go back to loiter mode the battery voltage works fine again. This may have been the same as yesterday, I just didn’t play close enough attention then.
  • MP build 1.3.8110.38294 on Ubuntu. (Also updated this morning but a different build number?) Anyhow, this one worked just fine. Same quad. Same mission. Same telemetry radios. Same muppet at the controls.