Battery remaining percentage stuck on 0%

Ok, i’m doing my first setup, i have the pixhawk 6c and the PM07 power board from Holybro. I am powering my setup from a bench power supply.

Everything was going great until I tried to setup the battery monitor. Now no matter what I do, the remaining battery percentage is stuck on 0% and i get the “Prearm: Battery 1 unhealthy” message and I cant get rid of it. Even selecting disabled for the monitor doesn’t get rid of this message.

Any ideas? Luckily I saved my params right before this operation so I can revert back, and then everything is fine again and it says 98% remaining again. Not sure why configuring the power monitor breaks the system.

I think I resolved this by comparing my params to the saved params. Looks like the default Pinout was correct but when I select a hardware version it changes to incorrect parameters. I found this on the holybro website: Power Module Setup - Holybro Docs

With Pixhawk 6C:

If using power1 port, go to “Config” tab and input the following in the parameter list:



Everything seems to be working again.

I had the same problem, BTW Pixhawk 6 uses digital battery monitor I realised. So my old Battery Monitor for P4 can’t use here. I mess up the other time the configuration as well. Took a day of figuring out with no available. Well until I search this forum up.

Thanks Joseph, yes the 5X/6X uses power modules ending in D (digital)(I2C), but it seems the 6C still uses analog modules.

For some reason when I tried to configure using the tab in mission planner:

  • Monitor – “Analog Voltage and Current”
  • Sensor – “9: Holybro Pixhawk 4 PM” (Holybro Power Module)
  • The “HW VER” – PixHawk
    it configured the pins to other than:

After using the tab to setup the PM07, I went back and changed those parameters manually and everything started working properly.

1 Like