Battery Monitor Strange Behavior

Upgraded from 3.4.6 to 3.5 RC7. Getting invalid current readings for battery monitor. Screen shot shows 660 amps when system setting idle. Orders of magnitude off. All worked okay with 3.4.6. Using MP 1.3.48. Suggestions? Thank you.

Reverted back to 3.4.6. Every works okay.

use beta MP :slight_smile:

What FC are you using? There is an issue I noticed in 3.5r6 where if you select the cube or pixhawk, it sets Batt_Curr_Pin to 3. If you have a Pixhawk 2, this param needs to be set to 14. I was having a heck of a time with both my voltage and amp reported values were extremely off. SpektreWorks figured it out for me and it now works great

@MichaelDS2242 This forum has a very good search function, I recommend that next time you use it to see if someone encountered your problem - which, in this case, several people did.

@flyboy369 I’ll have to ask you to stop spreading that false information. You are using Power2 port of The Cube instead of Power1 (which is an unusual setup) and you didn’t read the parameters description. I’ll quote what I’ve written on Facebook:

I’m not sure if I can provide some help here, but The Cube has two power ports. With Power 1 you still use pins 2 & 3, with Power 2 you use pins 13 & 14. This is documented in the parameters description:

Using Power 1 or 2 isn’t connected to using BATT or BATT2 parameters, you can select them as you wish - just remember that the BATT instance is the main one, the one used for failsafe and you shouldn’t use BATT2 without using BATT.

The Power 2 current pin was for some time incorrectly documented as pin 12, so that may be why some people had issues.

Thanks for your reply. Using original Pixhawk (clone) and clone battery monitor. All works okay with 3.4.6 and prior versions.

I considered that if the problem did not occur using 3.4.6 and prior versions but does occur (at least for me) with the just-released 3.5 RC 7, then it should be reported. Also, I have used the search function many times and it is not unusual to find posting of problems but no solution. Thank you.

You need to update Mission Planner if you’re seeing the amps and current used displayed wrong. That information is handled a little differently in 3.5+, and requires you update MP to account for it.

Nm a minute read fully

Thanks for the response. I’m using the latest released version (1.3.48). So, should I update to an unreleased beta version?

I’m having this exsact issue on a PH2.1 with Mauch 100A on 1 and Mini power brick on 2

To confirm I have spent 4 hours on this today.

If I have the Mauch on Bat 1 pins 2 and 3 set with the correct multiplyiers as supplied by mauch I’m getting Bat correct how current between 100A

Bat 2 is correct on pins 13 and 14.

If I swap them around including getting Bat 2 again correct but Bat 1 on 0

If I remove Bat 2 and disable and just use Bat 1 I’m getting current floating to 600A on pins 3, I have tried 14 as well

I’m using copter 3.5 RC7, MP 1.3.48 build 1.1.6330.31139

Now I have updated to beta MP but still current does not read, does not move off 0.01 now since moving to the beta MP

Stangly if I disable power current read so set to 3 I also loose any reading from no 1 too

really struggling with this

Ok I have spent hours on this today and I have got to the bottom of what’s happening

It appears MP bug that it is displaying power 2 on current so current 2 reading on both current and current 2.

Looking at the flight log it’s correct ,if you draw of power 2 port both Current and Current 2 display correct but the same so possible bug in MP.

This is on 3.5 RC7 and MP 1.3.48 build 1.1.6344.20357

OK anyone else getting this as its driving me nuts

Edit just downloaded today’s beta of MP and it’s been fixed


These changes should be noted when new releases come out, so we know that current monitoring in AC 3.5rc * has changed …Anything that changes in the code should be in the release notes…so we know what to look for. Other wise we will all spend hours try to fix something that is not broken …just need a new MP version. :scream:

1 Like

I am unable to receive correct current data, seems to display only the current used by Pix CUBE and attached devices. When I increase power to say 30A there is no change on the Bat Current (Amps) from the .23 (fluctuates).

I have attached my bat params, I really would appreciate some help.

Thank you for your time.

Thank you to anyone that had a look at my issue, I continuity checked power pin 3 (current pin) and discovered the silicone wire was detached from the pin header (visually almost impossible to see) hence the only reported current was from the running gear.