Servers by jDrones

Battery monitor can´t configure 3.9.4


(ginodouglas) #1

When I tried to configure the battery monitor in a plane 3.9.4 I got the message “This feature is not enabled in your firmware”.
I am using a HKPilot and a battery monitor both from HobbyKing. I tried also in a Cube with its battery monitor.
If I install Copter firmware everything is working fine with both hardware.
Thanks
Gino


(Nathan E) #2

Try changing the parameters manually. I’m guessing this is an issue with Mission Planner’s wizard, not ardupilot.


(ginodouglas) #3

Every time I tried to change the parameters I got “Set BATT_AMP_PERVOLT Failed”, “Set BATT_VOLT_MULT Failed” and “This feature is not enabled in your firmware”


(Nathan E) #4

Do you have BATT_MONITOR = 4? Are you connected via USB? Do other parameters set successfully, or it it just the BATT ones?


(ginodouglas) #5

The only problem is the BATT ones. I tried a beta version and have the same problem . When I downgraded to 3.8.5 everything is ok.


(Nathan E) #6

Are you using the full parameter list?


(ginodouglas) #7

Version 3.9.0 and 3.9.2 don´t have the issue with BATT, I can see it in 3.9.4 and a beta of 3.10


(Nathan E) #8

Are you running ChibiOS version of 3.9.4?


(ginodouglas) #9

I tried both versions, with and without Chibios, the issue exist in both.


(Nathan E) #10

Can you attach a .param file from your configuration on 3.9.4? I will attempt to load your battery settings on my cube running 3.9.4 and see if I can recreate the problem. This problem appears odd - I don’t have an explanation for you.


(ginodouglas) #11

This parameter file is from HKPilot:

spad3d.param (14.3 KB)


(ginodouglas) #12

It is working now in a Cube, starting with a 3.9.3 with BATT configured then upgrade to 3.9.4 with Chibios and it is still working. I wil try to reinstall 3.9.4 in HKPilot to verify.


(ginodouglas) #13

I tried to reinstall 3.9.4 in HKPilot and Chibios is installed but not the firmware, the mesage said it was already installed.
But now BATT is working!
Maybe a Chibios issue?

Thanks Nathan.


(Pacraf) #14

Dear Pilots,

It is a pity that I read that thread so late. I had the same issues like described here.

But my way of investigation was different (unfortunaltelly). Described here downgrading for setting battery worked also for me.

But anyway I have some doubts. What is maximum voltage level for [POWER] socket ADC (the pins for monitoring voltage and current.) ?

From documentation it is clear that 3v3 . But all cheap power modules have voltage Vbatt/2 divider. So in terms of 3S battery it means that often voltage is close to 6V on that input.

Seeing my battery monitoring troubles, and finnaly message “this feature is not enabled in your firmware”, I was sure that I destroyed my ADC inputs, and this is the result. So I installed additional divider, that now my full 3S battery voltage is 2,7V. But it seems that the trouble was not related to destroyed ADC( it works after downgrade firmware, and coming back to current, I can see voltage).

So what is true - are really pixhawk [power] socket ADC’s only 3v3 capable? or more? if you look on cheap sources of hobby parts, together with pixhawk they sell cheap power modules with U/2 dividers… but not too many complaints on internet forums… So that’s my doubts…