Battery monitor broken in mission planner

I’m using a pixhawk and a power module and mission planner won’t keep any of the settings i give it. I will try to select “other” and once you click out of the menu, nothing happens. Also, the voltage isn’t programmable either, it just stays the same no matter if you change it. This is really frustrating and it’s entirely unusable.

Do you write the parameter (by pressing the green “write parameters” button) ?

I’m new to this stuff, but If i change something in the battery menu, and I click out of it to go to the write params button, it has already erased what I did. Even if i write to the board, and read it again, its still the same because once you leave the menu, its already gone. heres a video i made showing theissue

Set the voltage/current monitor type, like you are doing, then reboot the flight controller. After that go back into the voltage and current settings andyou should be OK to calibrate and save.

Ok, I tried your instructions, I still cannot get the settings to stick like every other setting in mission planner. The video is below, their is a pause for a few seconds while I unplug and plug in the pixhawk as you can see from the top right hand corner. Thanks - Joseph

so after reconnecting, were you then able to set voltage scale and amps per volt or anything?
The video is a bit too out of focus to tell whats going on.
Post your param file.