Servers by jDrones

Battery falisafe option not shown in mission planner

In Mission planner i cant find an option for battery failsafe. I can set the Battery failsafe value but i m not able to see any modes like land, RTL,etc.
I can see the drop down box but not the modes.
When i click on the Dropbox its blank

Also i have a power module attached to my apm 2.8

Can anyone Help plz…

here is an image related to my problem

1 Like

That’s because that menu selection in Mission Planner is looking for parameter values that don’t exist in the firmware that obsolete Flight Controller has to use… Use the Full parameter list and make the selection from FS_THR_ENABLE directly. Of course don’t choose the SmartRTL options.

1 Like

I have enabled it in FS BATT and set its value to 1 that is land but even then its not working and my drone always crashes when its battery gets too low.
Also I have calculated my voltage using an multimeter and callibrated the values of the battery but still it dont works

Post a link to the .bin log file on the flight controller of the last crash. There is far less troubleshooting data available with AC3.2 from current but it may still have value if you turned on logging options.

okay i will post it soon because now i have plugged my quad for charging but plz reply when i post it

Sure. Headed out for the day but I’ll be happy to look at it upon my return. I would suggest 1918 for the log bitmask to capture the data we will need. So maybe take another flight after setting that. Or if more logging is turned all already go ahead and post what you have.

Okay sure Thnx for you help :grinning:

266 1-1-1970 5-30-00 AM.bin (759.5 KB)

2020-02-10 14-34-47.bin (762.6 KB)

Here are two log files, I m little bit confused which is the log file which consist my data so sending two of em

I think the topmost file is corrupted cause when I tried to open it using auto analysis it shows an error, but you try to open the file

my flight duration was almost 10:39sec after that my quad crashed

also when I was flying my quad my i switched it to alt hold mode and started a autotune but after 30sec my quad landed i dont know why. It happened to me twice and then at third flight when my drone was trying to land i switched to stablized mode which disabled the landing and then again put my quad into alt hold mode with autotune on. After around 8:00 minutes of flight time my drone became unstable and crashed but the failsafe was not triggered(also autotune was successfull).

But I dont know why my quad behaved like that. Even though I calibrated my battery using a multimeter(Not a cheap multimeter.)

I think failsafe was triggered too early i dont know why?

my battery was fully charged and its voltage was 12.56 when i armed my motors

also my battery failsafe value is set to 10.5.

Your battery voltage was down to 8.3V at the end of that flight and the battery failsafe was triggered very early in the flight. It switched to Land mode as it should and you overrode it by switching to stabilize. You did this 4 times. You should have let in land and not run Autotune. Also, you don’t have enough logging turned on to determine much else.

1 Like

But as I said when I started my flight the battery was 12.56 V and then after only 30sec failsafe was triggered.

can you tell the reason for that

My battery is properly calliberated and it has a discharge rate of 30c it is a 3s lipo battery

I would say the battery is bad.

Are you sure cause I have used my battery just for not more than 25 flights

Hi… I am also facing this problem… I read your conversation and do the same process but still I can’t see the battery fail safe option…
Plz help me


As @dkemxr said in the second post.

Servers by jDrones