Battery Failsafe not logged

Hi everyone,

I’m using ArduCopter 3.3.3 on a pixhawk board. The other day I was doing some failsafe testings, and intentionally let the battery failsafe trigger twice. Both times it worked correctly (drone entered RTL mode and landed uneventfully). However, the failsafe does not seem to have been logged on the dataflash. It is present on the telemetry log (if I replay it on Mission Planner I can see the “Low Battery” warning popping up when it goes to RTL) but on the dataflash logs there is no failsafe in the errors or events fields. Does anyone have a clue why this happened?

Thanks in advance for the help

Did you have enough logging set to display it?

I’m not sure I understand the question, do you mean if I had the correct LOG_BITMASK set? I believe so, at least GCS failsafes were logged correctly.

Might help if you posted the log.

2016-07-29 10-29-53.tlog (694.9 KB)

I attached the telemetry log. Unfortunately, it does not seem to allow me to upload the dataflash log (too big perhaps?).

At any rate, if you could check the dataflash log, you would notice the only errors logged are two GCS failsafe triggers. Those happened because I intentionally disconnected the GCS from the copter to test that failsafe.

In the telemetry log, you’ll notice it starts midflight and with a failsafe on. That is because that log starts when I reconnected the GCS to the drone after the second GCS failsafe. Thing is, if you replay the log on MissionPlanner, you can see that at around 10h30h28s a Battery failsafe triggers (I also noticed this in the field). This failsafe trigger cannot be seen on the dataflash log, and thus this thread.

Later that day I did another flight test with battery failsafe triggering and same thing happens: it can be seen on the telemetry log, but not on the dataflash one

Dataflash log is better; that way I can verify that the battery failsafe is enabled. You can set up the failsafe, but if it isn’t enabled it will never trigger.

I have tried many times but really am unable to upload the dataflash log; it keeps resetting the upload at 50% or so.

At any rate: the failsafe was on and it worked correctly. If you replay the telemetry log, you can see it firing at 10h30m28s. The problem is that the failsafe trigger was not registered in the dataflash log

Can you not upload to somplace like Dropbox or Google Drive and post the link? That’s the way most are done here when they are large.

BigTulsa thanks for taking time and interest in my issue. Here it is:

As you will see, the battery failsafe trigger is not registered in the log

Mind that the telemetry corresponds only to a part of the dataflash log; more specifically, it starts a few seconds after the second GCS failsafe trigger