Batch sampling frequencies seem to ignore the settings in params

I’m doing FFT analysis and I need the sampling frequency to be 1kHz (with 1024 samples in a batch = 1s long batches). The recordings I receive have 4kHz acc and 8kHz gyro sampling.

I know that with Ardupilot 4.1, “the backend rate has been made configurable for IMUs that support fast sampling”, so I set the INS_GYRO_RATE to 0, which should give “the same behaviour as previous firmware versions” - source

However, even after this change, the sampling is still 4kHz for acc and 8kHz for gyro. I attach the bin file and the parameter file, any input is appreciated.
x4s-1.param (17.1 KB)
2022-08-22 (986.0 KB)


Thank you, that solved it. I don’t find the parameter documentation on it to be clear enough and wanted to edit it, but I’m getting “404” (probably don’t have the rights to view it)

Thank you for the response, however, I have read through the guide before trying to make the change. Using the “Edit on GitHub” button (as instructed here), I get the aforementioned error 404, and could not even find the page in the repo manually. Since it clearly is stored in “/copter/source/docs/” and I cannot see it, I came to the conclusion that I do not have the privilege to view it.

You will need to fork and do a PR

Forking does not reveal files that I couldn’t see before forking.

you cannot edit the parameters.rst file…its auto-generated from the firmware code…the only way to change the metadata of a parameter is to do a direct PR to the firmware code base changing the file where the parameter is defined…
but I will look into that wiki page to see if I can make things clearer

1 Like