Basic Tuning not showing throttle


I was doing basic tuning of my pixhawk 2.4.8 which has copter 4.0.7 firmware but in mission planner under basic tuning tab, it is showing only Roll/Pitch Sensitivity and not showing Throttle Hover and Climb Sensitivity.

I tried installing the latest version of mission planner but doesn’t happen.
Anyone please help me in this.

Select ConfigPlannerLayoutadvanced.

The settings are already at advanced.

That’s all you get from Basic Tuning. If you want to use sliders (I never do) use the Standard or Advanced Parameters screens. Update to latest Stable version. Pixhawk1 is the correct firmware for that Flight Controller.

BTW If I change the firmware to Pixhawk1 then do I need to do all calibrations like Accelerometer, compass, ESC, Radio, etc. again??

No, all of those should transfer/translate over. What firmware version were you using?

But in mission planner, there is only Copter versions are available.
I can’t find any option for Pixhawk1.

You didn’t answer the question. fmuv2, fmuv3, Pixhawk1 ??

Currently, it has the firmware is Copter 4.0.7 which is provided by Ardupilot.

That doesn’t answer the question. There are many Arducopter firmwares. Post a screen shot like this after connecting to MP.

Cool, you already have the right firmware (Pixhawk1) you just need to update to latest Stable (4.1.5)

Thanks, let me update the latest firmware and try the basic tuning. May be this time it works :crossed_fingers: :crossed_fingers:

And I just need to update the firmware only…No need to do all calibrations???

I updated the firmware to 4.1.5 but again the same problem.
It is still not showing the Throttle Hover and Climb Sensitivity.

That wasn’t going to change with a firmware update. That’s all you get in that Basic screen. I was simply suggesting you update to latest Stable as there are many improvements since 4.0.7.