Basic Setup TBS Discovery --- PLS HELP

Hello everyone, I´m new to FPV flying and I have a fully assembled TBS Discovery.

My Setup:

TBS Discovery 450 Frame
DJI 2212/920 KV Motors
30A ESC’s from dys
Graupner E-Prop 10x5"
FrSky V8FR-|| 8 channel
4S 3000 and 5200 mAh Batteries
Turnigy TGY 9X

I want to use Mission Planner for my Project, but I don’t know anything more than the Basic/Initial Setup.

I hope you can help me out with some Information on how to programm my Drone and my Transmitter.

Thank you in advance.


I’ve changed the topic from “Blog” to “Copter 3.4”.

Thanks, I didn’t know that…

I am flying roughly the same setup (Upgraded to Discovery Pro after the crash though), with another radio and TBS motors. Basically you calibrate all the sensors/ESCs/radio, and it works. Autotune will do the rest, but the single battery may not last a whole session, so you may need to do one-two axes at a time.
Oh, almost forgot, what flight controller do you use?

Oh sorry I missed that. I am using a Pixhawk PX4.

What about the Transmitter Setup? Do I also have to calibrate the remote?

Another issue: Which PID’s should I use? Any advice?

You specified different brands of transmitter and receiver. Do you have the FrSky module installed in the Turnigy? If you have successfully paired your TX and RX, the next step would be the radio calibration in MIssion Planner. It should be a pretty straightforward step-by-step guided process (I have no Windows, therefore I’m using APM Planner 2 instead of Mission Planner).
The default PIDs are flyable, but an autotune will improve them. The wiki has lots of info on the whole setup process:

Indeed, I replaced the Turnigy module with the FrSky module.

I found this in a Forum. Are they suitable for steady and smooth flight?

Which values will increase diffidulty Level?

Sorry, I am of not much help in manual tuning. The only thing I adjusted manually is Rate Yaw P, because the yaw was too sluggish. Here are my current params:

Please note that my copter has more equipment on it, so it is pretty heavy. The same parameters could make yours feel very twitchy, or even oscillate. I still recommend using the firmware’s default parameters for first flight, and then run autotune sessions for all 3 axes on a calm day.

After you get it flying “Locked in”, i.e. flying smooth, no twitching, keeping it’s position in the wind, no overshooting etc., have a look at the RC_FEEL_RP parameter to tweak the way the copter responds to your inputs if you plan to fly by hand a lot.

Thanks a lot!

Yesterday I did a test flight with the standard Parameters. The copter is not quite stable but I will fix this issue.

Maybe today…

1 Like

Does anybody know how to setup the OSD in the FPV Google’s correctly?

I am using Quanum FPV Googles.


  • My flight mode Switch on the Transmitter does not Change the Mode. Do I have to change them on the Transmitter or in Mission Planner?

  • I am also using two different Batteries : 4S 3000mAh and 4S 5200 mAh. The preset in Mission Planner is the smaller Battery. Do I have to Change the Settings after every Battery Exchange?

Thank you in advance!!


I can’t help on the Goggles topic.

The flight mode change is influenced by two things:

  1. Setup of channels/pwm values being transmitted by your RC transmitter
  2. Config in Ardupilot (via missionplanner) that you do

It’s described quite well here I think:

Maybe have a look there?

And on the battery setting. i am assuming you are referring to the battery capacity setting where you enter the mAh value. It’s used to calculate when FS needs to kick in(and some other things), so yes, you will need to adjust it when you switch from a larger to a smaller battery. Or you leave it at the lower setting (not leveraging the full capacity of the larger battery). There is no way around this - unless with smart batteries - the system cannot know how much capacity the battery has - you need to tell it. My solution to this issue - always use batteries of the same size - then you don’t need to worry about it.

Hope this helps a bit,