Servers by jDrones

BaroSensor and Airspeed compile error for AP and PH4mini

Build failed
-> task in ‘objs/AP_Baro’ failed (exit status 1):
{task 140145095425232: cxx AP_Baro_UAVCAN.cpp -> AP_Baro_UAVCAN.cpp.0.o}

I do not understand why UAVCAN, the Pixhawk 4 Mini has MS5611 Barometer.
Or is UAVCAN for all devices?
Or is the reason, a wrong BRD_TYPE?

-> task in ‘objs/AP_Airspeed’ failed (exit status 1):
{task 140145095423440: cxx AP_Airspeed_UAVCAN.cpp -> AP_Airspeed_UAVCAN.cpp.0.o}

Someone with ideas?

Try doing “git submodule update —init —recursive”

Many Thanks,

please, can you write some words to this step?
I’m new here and interesst in such details.

No worries. On the command line in the ArduPilot directory, type ““git submodule update —init —recursive”.
Note that — is two - (not a single long dash).

thanks,

the compiling now works, but the old errors are back.

BRD_TYPE: 24 unknown
available are the following options:
0:AUTO 1:PX4V1 2:Pixhawk 3:Cube/Pixhawk2 4:Pixracer 5:PixhawkMini 6:Pixhawk2Slim 7:VRBrain 5.1 8:VRBrain 5.2 9:VR Micro Brain 5.1 10:VR Micro Brain 5.2 11:VRBrain Core 1.0 12:VRBrain 5.4 13:Intel Aero FC 20:AUAV2.1

Barometer not recogniced
Bad Gyro health

I have the pixhawk 4 mini.
It could be the same like pixhawk 4, but PH4 is also not an option.

MP:1.3.68
QGC: daily build

Build target should be PH4-mini

Perhaps upgrade your bootloader. Download a ph4-mini firmware from firmware.ardupilot.org and flash as a custom firmware in Missionplanner. Then reboot, connect, hit CTRL-F and click the bootloader update button.

With any luck that will get you sorted out.

Regards,

James

There is the choice:

arduplane.apj Sun Sep 15 12:19:01 2019 855789
arduplane.hex Sun Sep 15 12:19:01 2019 2666704
arduplane_with_bl.hex Sun Sep 15 12:19:01 2019

I use apj, hex, or bl.hex?
There is no option to burn imadiate with bl?

I try to do this with the following result.
MP say to me, firmware upgrade not nessesary, because allready on the board.
The Bootloader Upgrade looks like the same. nothing happens.

I try to do this with the no result.
MP say to me, firmware upgrade not nessesary, because allready on the board.
The Bootloader Upgrade looks like the same. nothing happens.

???

Use the apj file with Missionplanner.

To answer what I think was your question, you can build a bootloader and flash it from the command line, but it’s a bit more complicated to explain how to do it. Missionplanner is easier :slight_smile:

Regards,

James

Please read the point 1 one more.

BRD_TYPE:24 comes with the Firmware 3.10 or also 3.11.
But the option 24 (PH4-mini) seems to be not known in MP and also QGC.

It seems to be, that the firmware has no option 24 insight. The Bootloader make what? It passes the parameter 24 to the Firmware?
Then the Firmware is not correct in my opinion.

Or is there a problem with the change from IMU-Mask to BRD_TYPE?
So the Bootloader has to be adapted to BRD_TYPE?

I have not enough insight in tho the code.

The bootloader update should work. You might need to wait a little longer: a message will pop up when it’s complete.
If that doesn’t work, try the latest Missionplanner and see if it’s still an issue

I think the Mission Planner has updated the boot loader now and after this the
QGC -> Firmware -> Advanced -> Flash chibios bootloader too.

But without success.
The Error Message comes and the B/E led flashes red.
Possible, there is another problem.
Is there a way to debug?

plenty of ways to debug. Firstly, does this happen with a firmware from the groundstation or firmware server, or just when you compile your own?
Also, I did a couple of tests on a Windows machine today. Strangely, I had to run QGroundControl as Administrator to get it to connect. That shouldn’t be necessary, and is likely a permissions issue on the PC I was using, but worth checking.

James Pattison,

you here? I’m desperate. (:
What i observe is the following.

  1. QGC has a parameter BRD-TYPE, can you check this parameter and search for an option like PH4 or PH4mini?
    I can not find this option.
    QGC or MP is the same behavior.

  2. Allen Tseng write, PH4Mini works with beta-3.6.10, i try this and see the same behavior.

I have testet many stables, betas and my own compiled Firmware.
Every time the same behavior.

So i think, there is no support for PH4 today.
Or have i to add a special submodul for PH4?

For me, it looks as if the ardupilot had no support for PH4.

But in the Ardupilot-Firmware-path there is an folder with the name PH4-Mini.
So there is an support allready. I’m confused.

There is definitely support for ph4-mini. I have one on my desk that has been flying for months.

I’m a bit stumped by why your board is misbehaving.
Try the Daily QGroundControl build.

Regards,

James

I have the daily QGC allready.

In ardupilot i see the Red LED is blinking after boot up.
So the Problem is not in the GroundControlSoftware.
2.
In PX4 with Attitude Calibration i get the Error: attitude estimator not running - check system boo
And if i make a PreArmCheck i get the error: BaroSensor #0 missing.

I try to change the hardware.
Possible the BaroSensor is damaged.

BRD_TYPE is 24

Regards,

James

Servers by jDrones