Servers by jDrones

Barometer via UAVCAN Zubax does not work

Hey,

I am trying to use the Zubax GNSS 2 with ArduCopter (v.3.5.0). GPS and Magnetometer are working fine. I enabled the barometer on the Zubax with 50 Hz. I used an oscillloscope to confirm, that the zubax sends the barometer message. I set the GND_PRIMARY value in MissionPlanner to 1. But still the Pixhawk uses his internal barometer values. Am I missing something in the configuration?

Thx
Jonas

Hello jonas
Please look at docs.zubax.com/zubax_gnss/tutorials/using_with_pixhawk
Sounds good to me …

I already tried that. I tried the tutorial for zubax gnss 1 and zubas gnss 2. I tried to confirm, that it’s using the right compass, therefore I put the Zubax in an plasticbag and increased the pressure, but the absolut pressure and relative pressure and the height in MissionPlaner kept around the same value.

Okay, i managed to get it working with ArduCopter v. 3.4.6. I realized, that the press_abs value is from the internal sensor, but the height is still adjusted with the external barometer. I will try later this day, if I manage to get it working with 3.5.0

JonasM - what is the status of the barometer issue resolved?

I tried all the possible solutions and hacks. On 3.5.4 it just doesn’t work.

Keep getting “bad baro health”.

It is a shame since it was working perfect on 3.4.6.

Corrado

Is there any news on canbus???

Corrado

Any word on this, I am curious as well. 3.4.6 is fine but is missing the NTF_Display function. Not the end of the world, but it would be nice to have everything working as intended.

Servers by jDrones