Baro Config Error After Connecting M8N GPS|| No Compass

I have a Holybro F4 kakute AIO v2 Board.
Running Adrupilot firmware.
When I am connecting the M8N GPS + Compass module.
to R3, T3 pads for Tx and Rx Connections and R6 T6 for Telemetry Tx and Rx.
As soon as I connect the GPS,Compass module I start getting the Baro Config Error.
When I unplug the GPS module the Baro config error vanishes.
I was earlier working with 4.1.5 firmware version.
Now I have updated the firmware to the latest. Still I get the same error.
Also in MP Compass is not getting detected.

One thing you can try is flashing a different version of ardupilot to erase the settings or betaflight or something then flash back to ardupilot.

I had weird bizarre issues with mine and that seemed to resolve it.

Yes, I have seen this before. Flash plane and then copter again - that will fully erase the parameter data

I will try that and let you know, I tried what @bonkas has suggested. It did detect the GPS.
Steps.

  1. Flashed Betaflight then flashed back the arducopter 4.1.5 version.
  2. Connected MP and then updated the firmware to 4.2.1 and it detected the GPS.
  3. However Compass is not getting detected.
    Btw is there a way to save the parameters and load them after new-firmware flash.?
    @andyp1per I will try flashing the arduplane and then re-flash the arducopter.
    I do suspect, when I configure below params they stop working.
    BATT_MONITOR 4
    BATT_VOLT_PIN 13
    BATT_CURR_PIN 12
    BATT_VOLT_MULT 10.1
    BATT_AMP_PERVLT 17.0
    There are 2 battery monitors , should I configure both or only Bat-Monitor-1.