Servers by jDrones

BalanceBot Crashing In Acro Mode

I need some help trying to set up my BalancingBot in Acro mode. When the flight mode is switched to Acro mode, if violently spins up. See the video. Left motor is set to servo1 and the right motor is set to servo3. The left encoder is plugged into 3&4, and the right encoder is plugged into 5&6. Both encoders track rpm in the tuning screen, however nothing appears in MavLink Inspector pertaining to the encoders.
Can some find out what is wrong?

Chuck

Rover V3.5.2
Pixhawk 4
BalanceBot12-2-19-2019.param (13.4 KB)

https://smile.amazon.com/clouddrive/share/dbVAfBQqg7aSQ0dAbWYcQfsE0XJ30ilxEeywSDj3wOS - log
https://smile.amazon.com/clouddrive/share/FDNHtjWcJbi0DzeJO0DgpRYCgBUb7gg4hTE63nL6mck - movie

Really frustrated here. I want to go back to ArduRover Ver 3.5.1 because I know that worked with my setup, but I can’t figure out how to do it. The drop down box for selecting V3.5.1 doesn’t show it as an option. I don’t know how to install the firmware downloaded from the repository. Any help would be appreciated.

@chuckl74,

go to this website(ardurover firmware 3.5.1) download the correct firmware for your board click that firmware and download the APJ ardurover.apj (782.2 KB) I have included the 3.5.1 firmware in this post for you to download. All previous firmware can be found here.

Then in Mission Planner go to initial setup and near the middle of the screen you will see an option to load custom firmware find the apj firmware file you just downloaded and select it click OK and you should be able to load it.

That’s exactly what I tried several times with no success, thus my frustration. Well, today it worked. Thank you!

Chuck

This is extremely frustrating and has consumed a lot of time. Even with V3.5.1 it just spins up like crazy in Acro mode. Even with the parameters when Acro worked about four months ago, it won’t work right now. When it was working, it worked in Auto, being able to track through way points.

I hate to give up, but if anyone has any suggestions, less hear them.

Chuck

Servers by jDrones