Servers by jDrones

"Bad terrain or ground data" loading terrain follow mission in plane

I now have the ‘Bad or no terrain data’ error when planning a terrain following mission in my plane. Terrain following enabled in parameters in mission planner. See screenshots.

When connected to my laptop in Mission Planner it’s not showing any altitude which it always did (circled) and the terrain data remains pending and doesn’t load. The Pixhawk main light is flashing yellow.

The GPS module green light is on, and the blue light flashing.

I have tried older firmware in the Pikhawk and an earlier Mission Planner, formatted and changed SD cards and even swapped in my other Pixhawk but no change. This just suddenly started.

Question does mission planner have internet it may be trying to down maps for the aera your flying ?
i did read somewhere they have change the way MP/ArduPilot downloads the maps

Terrain

A bug fix in the format ArduPilot uses to store terrain data means that your flight controller will need to re-download the terrain data onto the sdcard via your GCS. If you fly without a GCS and you use terrain data then please re-download the terrain data you need by setting up a mission when you have internet access and allowing your flight controller to request terrain data from your GCS.

are you using plane 4.0.5 ?

Yes, tried again on 4.04 but the same so back on 4.05.

I do have internet when I try uploading the mission. This only started about 3 weeks ago. I’m doing nothing different. I always fly without a GCS so always upload the mission in advance.

Yes, fast internet connection when loading mission.

check your prams file TERRAIN_OPTIONS =1 it will take some time to down load then and the planes need to have a gps lock out side as well

TERRAIN_OPTIONS: Terrain options

Note: This parameter is for advanced users

Options to change behaviour of terrain system

Bitmask
Bit Meaning


0 Disable Download

TERRAIN_OPTIONS =1 set and always has been. As I say, it worked fine until a few weeks ago and I suddenly started getting the “Bad terrain or ground data” error and the loading of maps stays pending.

Hey Park, I had the exact problem this week. It was my SD card. It was recording logs, but not terrain which threw me off. Then when I put in another SD card IT was bad too, which made troubleshooting really hard. Finally figured it HAD to be the SD card so I got a good High-Speed Sandisk card and it solved the problem.
Sounds like your SD card took a sh8t, just like mine. Also the ones that come with the pixhawks are usually super cheap.
hope this helps

Servers by jDrones