Bad Proximity Readings Using Lightware SF40/c

Having an issue with “false” obstacles being detected with a Lightware SF40/c. The issue can be seen in the attached log file as well as the below proximity plot. The 4.49 m “blips” cause BendyRuler to reroute when in fact there is no object present.

PRX_FILT = 0.25
PRX_TYPE = 7
SERIAL2_BAUD = 921
SERIAL2_PROTOCOL = 11

We have tried alternative powering, swapping TELEM ports and changing PRX_FILT to no avail. The 4.49 m is constant in these plots which seems to indicate that the PRX is “dropping” or simply setting to that when there is no data available? Any suggestions are greatly appreciated!

https://drive.google.com/file/d/1-Ww0AiQI3yxT4pYZlODDCiALqES_I16B/view?usp=sharing

Went back into an old flight log with a different vehicle but same exact hardware setup. Below is the PRX CDist plot showing the same 4.49 m “blips”

link to log: https://drive.google.com/file/d/1y2w6aXPjc99lSJ2iPsV6ula2-F6__7TD/view?usp=sharing

Use shielded cable for the Lidar setup, check lens for scratches/dirt. There were also different version of the sf40c, that “might” be an issue…

Block off any direction that is not absolutely needed to cut down on reaction time and processing use. Use only cube orange for lidar as it’s processing intensive.

Put everything lidar related back to default values.

that’s all I can think of for now.

@Chad_Frazer Appreciate the input! We are using a Cube Orange so I had assumed that processing power wasn’t an issue, but widening those ING_ANG to anything we don’t need is a great idea. We will try those items shortly.

Here is a new log, ignoring all angles outside of the 135 degrees ahead of the rover.

https://drive.google.com/file/d/1VtCo0a2F4N6X1Tl8JYc-b00cFMlixhpK/view?usp=share_link

Because this didn’t help the issue, we also tried changing the baud rate to 115200. This also did not fix the issue.

@Chad_Frazer Wondering if you could elaborate on the different version of the SF40c that you said “might” be an issue.

I noticed that the version I have is one that you can’t update, which is the first thing I do before I mess with most hardware. There simply is no port/usb/whatever to plug into to do that. If you look at the ardu wiki and on some places on the web you’ll see a version that you can update, usually it has an exposed red circuit board in the pic of it. If you have one of those, it’s an older version which might require you to update it.